[S922X] X88 King

Hello,

it’s been a while since this box was mentioned on this forum, so i like to bring it up again. We know that ethernet is working on this box working with coreelec. Now the usb support is still missing. And the box, it keeps on triggering the hdmi port, even if the box isn’t powered to mains. My question is, whether there are chances the usb will get supported in future?

grtz

@mark1978 Keep all issues regarding this box in this thread / topic.

@mark1978 please try these dtbs here and here and let me know if there is any change.

@anon88919003

g12b_s922x_4g.dtb : stuck at bootlogo

g12b_s922x_4g_rev_a.dtb : message device tree too old, then normal boot, then no network and no usb.

Will give the first device tree a second try.
This g12b_s922x_4g_rev_a.dtb from the daily coreelec image works still best.
Network is working, usb is not. dtb.img (84.6 KB)

I need the original Android device tree to compare it.

dtb.img (256 KB) Isn’t this the android device tree? Just not in text format.

Try this one here.

usb is working !! Just it seems now the ethernet isn’t working. And out-of-date error.

What device tree was you originally using with working ethernet?

dtb.img (84.6 KB) This one.

Strange as ethernet is the same in both, can you try this.

ethernet is also working now. Must have had the router set to block things before. Usb 2 and usb 3 is working. Marvelous. Just it keeps saying the device tree is out-of-date.

excellent I will make sure it is included in tomorrows nightly and then the out of date message will disappear

sorry, the ethernet, there is still some trouble with it. I can’t use the http remote and if it is on dhcp mode, it keeps saying configuring.

Well, maybe the problem is more, that the dhcp is finding some strange ip adress for the box. Not from the router.

Have you tried to configure a static IP?

yes, tried numbers to the router, then it says connected, shows the right numbers, but i still can’t use the remote over lan.

Sorry I don’t understand what you mean by “use the remote over the lan”?

by the browser of my phone. So, the ip adress of the box followed by :8080.

Must be a unknown bug in CE

or an user fault ?

with dhcp it fills blanks in in the gateway address bar. With static ip address it neither works.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice