Screen 5% Too Big for Videos Only


#1

So, I just got an Android box to replace my old PC. Got a Samsung 32Gb SD Card, installed CoreElec and booting to that. Loaded up perfect the first time, screen size it perfect, no issues at all. In Android, screen size is fine as well.

I play a video, and the screen increases by 5%. If I click to bring up the bottom bar menu (pause, skip, settings, subs etc…) it’s partially cut off as well as the time in the upper corner (using default skin).

When I stop the video, it switches back to the main Kodi screen and for a moment it’s too big then flickers and shrinks back to proper size.

When playing a video, if I go to Zoom and custom, bringing it down to 95% is the perfect size.

I went to the video calibration screen in settings, it’s set to 1920x1080 and it’s exactly how it should be sized. When playing a video, if I bring up the tool bar and go into settings there and video and do the calibration there, I can get it to the correct size, but going from video to the main screen and back still causes the screen to go black, then come up too large and flickers back down to size again.

Any ideas? I thought overscan or something but, again, Android is fine, Kodi is fine… only video playback is wrong.


#2

You have to calibrate it for each resolution/refresh rate of video. The black screen is you television switching from one screen size and refresh rate to another. Depending on the make of tv there may be another way to calibrate. On some LG TVs you can go into Aspect ratio and select JustScan that normaly will make the picture fit the screen in most or all resolutions. On some older tvs if you plug into the HDMI socket marked DVI or tell the TV its a PC input the picture will normally fit properly.
When I set up a box for people I usualy set it up with about 5 / 6 videos and that normally fixes it


#3

I’m a bit confused… why?

I’ve been using OpenElec for over a year, switched the LibreElec a few months ago, now using CoreElec. Before all that I used Windows for a few years with Kodi. Never had these issues.

I have Kodi setup at 1920x1080 and the videos are 1920x1080… shouldn’t be any switching, should there?

So… I have to go into a half dozen random videos, pause it, go to the bottom tool bar, go into the video settings there and do the calibration for each?

How do I stop it from going to a blank screen and momentarily shifting in size and back? Again… Windows/OpenElec/LibreElec for the past 6yrs, same TV… never had this issue.

:thinking:


#4

You Probably have it set to 1920x1080 60Hz Most films will be 23.976Hz and TV content could be 25Hz. On OE/LE/Windows you probably had Adjust refresh rate turned off in the player settings . This meant all your content would have been scaled to the gui resolution and refresh rate. The problem with that is you introduce micro stutters and jumps as the display tries to convert 23.976 frames / second to 60 frames per second in does this by duplicating frames or dropping frames. Older TV take a long time to switch My 8 year old LG took 8-to 10 seconds during the switch. You can turn off “Adjust refresh rate” in player settings and everything will be displayed at the GUI frame-rate so no black screens but during panning and high speed scenes you will notice jumping. I have a lot of different content at different resolutions and frame rates so I have to calibrate a lot, you only need to calibrate once / resolution/ frame-rate but its worth it in the end. You may only need to do it on a few items if everything is at 1080 resolution.


#5

Did you go into Settings / System / Display
Whitelist and enable any resolutions ???
See Screenshot of my 1080p TV


#6

To ensure that the screen displays correctly in each supported resolution

No, calibrate the video from the System/Display page in kodi settings :wink:


#7

System/Display calibrated the main window, didn’t do anything for videos. Calibrating from the bottom tool bar while a video is playing worked.

Whitelist wise…

When I was trying to sort this out, Recommended Settings said to deselect everything in Whitelist, save the 1920x1080@60 setting.

ffimon’s method worked. I get the pause/screen resize going between video and menu, but after I calibrated 3 or 4 videos so far they all seem to be properly sized.


#8

Over scanning is a throw back from analogue TV days. The picture was deliberately stretched beyond the size of the screen because CRTs screens were not square. Also in the UK and some other countries they used the first 10 or so lines to transmit digital data for TELETEXT. if the TV did not overscan you got an annoying flickering pattern at the top of the picture.
https://www.howtogeek.com/252193/hdtv-overscan-what-it-is-and-why-you-should-probably-turn-it-off/
It would of been nice if the HDMI spec would have included some sort of Metadata to tell the TV not to overscan Maybe it does. On some TVs the HDMI socket marked DVI assumes a PC input and does not overscan when you use this socket. A lot of manufacturers have a way of turning off overscaning It’s just a case of figuring out what it is LG call it JustScan I think.


#9

Try 1920 x 1080 50Hz
Start play back of movie and then SSH with
cat /sys/class/amhdmitx/amhdmitx0/config
see what reads out.