Slow down of Hyperion.ng

there it is. sorry for german screenshot

It’s a Hyperion parameter in the “Image processing” section. I rolled back to the original CE and plugin just to make sure it doesn’t seem to me, and now i’m sure: UI smoothing doesn’t work properly. Smoothing - it’s an image postprocessing built-in the Hyperion, which interpolate color changes (in a set period of time) and spread result over desired FPS, regardless of grabbing FPS setting. Also, if a color change pretty fast (f.e. from white to black immediately), thanks to smoothing it “fades” stepless for some time. So we can have smooth output and “fluid” intercolor changes with any FPS (i use 50) although grabbing FPS is only 10 or original image changes too fast. In the latest build “fading” between color change have the right duration, but not stepless (jerky a bit). But frankly spoken i’m not so much care about UI :slight_smile: Video smoothing looks working ok, but i need more time for testing (need to find an appropriate testing video first).

Yes, my thoughts are same :slight_smile: Maybe it’s a good idea to make adjustable delimiter for each major FPS via config.

Not certainly in that way :slight_smile: As i said above, smoothing not only for increasing output FPS but also for the color change time interpolation (which is good for visual experience).

Disagree, see above.

I do not have any value for smoothing:

And it is smooth:

I also tested the frames/second detection and it can be automatically calculated. So I will limit the capture if frequency > 30Hz to capture only each second frame.

Really strange. Maybe you should try to change settings level to “Expert”? But even with “Default” I have this setting:

Camera doesn’t reproduce slight flickering. I really don’t want to bother you with UI-grabbing (as it’s not so important), but if you want to see difference by yourself - you have to rallback to original CE, and then I would suggest you the best way to see that difference.

Good news, thank you again :slight_smile:

Edit1: I think I found the way to record the UI-smoothing issue. I’ll try do it and upload video tomorrow.
Edit2: Here is the link to a couple of slow-mo videos, both filmed with exact same Hyperion configuration and at the exact same speed. There clearly seen that generic build has more “steps” in fading effect that test build has. I think that’s because test build ignores smoothing FPS setting (25Hz in my case) and uses grabbing FPS setting instead (but it honoring smoothing duration setting somehow, as color not blanking immediately).

I could not see any flickering or any annoing thing. so GUI is “fine/smooth enough” for me.
I am totaly happy how hyperion performs now
(live tv for about 2-3 hours and NO SINGLE SLOWDOWN, amazing!!)
@Portisch you really did a great job!

thx!

Here is the last test version before I push it to the repo:
[Image] + [Addon]
Only this combination will fix the slow down issue!!

The OSD will use 20Hz grabbing frequency, the video capture frequency is 1:1 like the frame rate.
If the frame rate is more than 30 frames per second only every second frame is captured.
Also 4k should work - I can’t test it.

Please upgrade booth! Image (devel-1553760991) and addon (9.0.1.100.2)!

Edit: Maybe you will need this in hyperion.conf.json if no LEDs are on:

    "instCapture": {
        "systemEnable": true,
        "systemPriority": 250,
        "v4lEnable": false,
        "v4lPriority": 240
    },
2 Likes

Wow really really great job, today i will update to this new version.

But yesterday I’ve watched livetv and mkv movies about 4h and 0 slowdowns.

Now I only want to know if it’s possible to turn off the leds in kodi menus, my box is on 24h and I need to turn off they in the UI

1 Like

So if the grabbing frequency will be adjusted to the video - this means that the frequency set in the Hyperion config will be skipped?

I can confirm that this new verison works with H264 4K non-HDR movies as well, thanks for that!
The other file I was trying to test with was a hevc 4k HDR file, there the leds either remained blank or showed some random static color, so it seems that it is not (yet :wink: ) working.

I don’t think it is the same issue.

1 Like

Yes, it is more “user + developer friendly”!

I uploaded two more slow-mo vids of smoothing testing whilst a video grabbing (“video_” prefix). As i can see, smoothing doesn’t work for it either :frowning: Dear @Portisch, i express my deepest gratitude to your work, and i will use it “as is” with my pleasure for sure (coz it’s awesome)! But if you have an interest yet - please, look into this problem too :pray:

@benoe, it was discussed many many times before :wink: For example, here is described a simple solution for HEVC, but keep in mind, that it heavily loads the RAM’s I/O, so you can face some trouble (artifacts or even system hanging) on cheap boxes.

What I miss is the part what is on the TV screen. Otherwise I can not reproduce the issue.

Just instant (literally, per-frame) color change from blue to black. I use this video for testing, smoothing was set to 50Hz. My eyes pretty sensitive (above overage), especially as for strobing effects, and i can see the difference with an unarmed eye. That’s why i recorded slow-mo videos for you :slight_smile:

So by entering that single line hyperion and framegrabber will work on H265 files as well?

echo 1 | tee /sys/module/amvdec_h265/parameters/double_write_mode

This is not clear for me.
First: You know the framerate of this video? Remember the frame grabbing speed == frame rate. So do not use video’s with a low frame rate like 24Hz.
Second: You talked about OSD (user interface) and not video!?

I believe, it’s my bad English, sorry :slight_smile:

  1. Hyperion has built-in smoothing mechanism, which interpolate color changing. It calculates missing intermediate colors if the LED output FPS set higher than grabbed FPS. So for your latest implementation, it should be like that: video frame rate (f.e. 24Hz) == grabbing speed (same 24Hz) != LED output frame rate (50Hz thanks to smoothing). And resulting LED output should be stepless and fluent no matters how low original grabbed FPS is.

  2. Firstly i noticed and reported the problem with UI, and promised to check the video grabbing either. Later (today) i checked it and confirmed that video grabbing doesn’t use smoothing either.

No, this line actually makes the video output corrupt.

If you set your screensaver in kodi to black your leds will turn off.

That’s how i do it

Yes, I am doing the same at this moment, but if there’s an option to skip the UI grabbing like in standard Hyperion with kodicheck, it will be better

About | FAQ | Terms of Service | Privacy Policy | Legal Notice