Slow down of Hyperion.ng

#131

I didn’t change anything about this and I used the source what is used at 8.95.7. And this is not part of the testing…

#132

I reboot my system but still nothing.

I will try the original add-on

#133

its true, the webserver does not apply changes (but i don´t know if it was working before :stuck_out_tongue_winking_eye: )
but its a test for fixing slowdowns, so let´s test and report if slowdowns still appear.
I am at testing at the moment… we will see results in a couple of hours.

#134

My web interface for Hyperion.ng works fine with these modified binaries.

#135

Here is one more a optimized version:
[Service.hyperion.ng-9.0.100_v1.zip]

And I just got an idea to make one more improvement but I have to check first tomorrow…

#136

Again an improved version:
[Service.hyperion.ng-9.0.100_v2.zip]

EDIT:
I did had one slow down in the last 2h with V2.
So I do have also a small modified kernel for S912 and S905. Just update your system like normal.
You can “downgrade” also as normal. Put the .tar archive in the update folder. The kernel do have only a small modifiation for the amlogic video grabber - nothing else. Rest is the same as 8.95.7.

#137

Yes. I made the same experience. Roughly every hour there is a slowdown, it feels like the slow down ist not as slow as before but this could be just my feeling about it.
I will try your modified kernel tonight.

Edit: with modified kernel i can see the RX-LED of arduino is flickering now instead of steady light but ambilight ist running smooth. promising :wink:

#138

I just installed CE update and addon update. I’ll report back if I’ll notice any slowdowns. With the addon only installed (no CE update) the slowdowns were still there. We’ll see how it is with this CE mod.

#139

The Slowdowns are still there :roll_eyes:
I was watching TV/Movies the last three days and slowdowns still appear in diffent intervals between 30min and 1-2 hours
@Portisch: do you still have an idea to fix this annoying issue?

#140

Currently I used the amlogic grabber.
Right now I try to get the ge2d method running. But this fail loading the driver. Also the original plugin fails so I have to find this bug first.

EDIT:
I think I found the issue why ge2d mode isn’t working. When the frame grabbing is starting the “display” in the amlogic video driver isn’t ready yet. This leads to a error and hyperion.ng is stopping using this grabber engine. The amlogic grabber is using a retry with 100ms delay. First I will try to force the usage of the ge2d driver and just ignore the failed grabbed frames…

2 Likes
#141

Thanks for your efforts, wish you luck!

#142

I got the hyperion linux patch fixed for the ge2d mode.
I just started testing so I do not have any result yet if the slow down is gone or not.

This version of the addon is only working with this modified kernel!!

[service.hyperion.ng-9.0.100_ge2d.zip]
[Image S912 based on 8.95.7]
[Image S905 based on 8.95.7]

2 Likes
#143

Can I upgrade the existing installation with modified kernel?

#144

Yes, maybe it is better to upgrade first to the official 8.95.7 kernel. Check if everything is working and backup of your settings in Kodi. Then upgrade with the kernel above.

1 Like
#145

I will try your new modified hyperion/kernel version tonight.
Thank you very very much for your effort!

#146

I took a look to the CPU usage of hyperion.ng.
The amvideocap (Amlogic video grabber) version to have ~9% CPU usage on my system.
The ge2d version do have ~19% CPU usage.

So the amvideocap methode is prefered and I have done some optimization of the amvideocap driver:
[S912/S905/addon download folder]

1 Like
#147

Yeah it’s known that GE2D uses more cpu. However I’d be happy to sacrifice 10% more CPU usage to get rid of the slowdowns.

#148

What a happy day! Thank you very much! I’ve been testing your ge2d-version for 5 hours already - no glitches so far :smile:
Amcap has a good performance, but it can’t grab 4k-video (which ge2d can). But still it would be amazing to have both techniques to choose!

#149

Hmmm, not sure if I’m missing something here, but I’ve been grabbing 4k with amvideocap just fine.

Good to hear GE2D isn’t producing slowdowns so far! :slight_smile:

#150

I am testing the new amvideocap version for 1h now, no slow downs so far. Normally I do have a slow down after ~2h. And I think I got a slow down with the ge2d version - but I am not 100% sure.

Edit: with the new amvideocap version it looks like the slow down looks different. It is not really a slow down, it looks more like “missing” frames in the stream.

Edit2: a slow down again :frowning: so back to the ge2d version…