SMB - shares not showing in CE BUT they do in Non-CE

Have an android TV box AMlogic 912 and have put CE on it (8.95) …

On the Kodi version that comes with Android TV (and on all my windows / Mac kit) I can easily see my Western Digital box (MyCloud device) via the SMB option . On the CE version it doesnt show me any of my SMB shares …

i can get to it via either NFS (IP Address) or typing in the whole server path to network sources (which it shows as SMB!! )

Seems like its not as optimum as it should be.

I am however wondering if there is a network issue though as the Library Update with around 300 movies and maybe 20 TV series and a total of about 400 episodes is taking forever… Certainly nowhere near as quick as the same box running Android TV …

Could they be linked?

The box has Gigabit Ethernet (as has all my other kit) and I know i set up the right DTB file for it but how would I see if there is an issue from an SSH session?

You said “on the CE version it doesn show any SMB shares”

But then you say that “I can get to it … typing whole server path (which shows as SMB)”

So which is it? Are you saying you can only access by typing the path, but doesn’t show by browsing?

I can say I use CE 8.95 and WD MyCloud (the old one, not the new stupid MyCloud Home). I very easily accessed the shares on it both with NFS and SMB using the Add Source, and Browse.
Although I only accessed files in the “Public” Folder, not special shares - don’t know if that would be different.

so if you are in Kodi on CE you get the various options to connect :

  1. NFS - works by keying in the IP address and the path to the storage area on the Mycloud
  2. windows network (SMB) - doesnt find anything but should come up with WORKGROUP to enable access to the media
  3. Add network location - works if you key in the full path name so you get smb://wdmycloud/media directory

However in normal Kodi on the Android system of the same box windows network (smb) does work and it works on all the other Kodi installs i have from android phones to windows 7 through to my Mac …

So something isn’t right on the CE build here OR the T95z ethernet connectivity is fubar’d on it

I also only use the PUBLIC folder for sharing this stuff…

Try using zeroconfig option to access your SMB shares. It works for me.


Thanks but you’re missing the point. There is a difference somehow with CE and base Kodi on any other hardware here.

Now is it because of a potential network issue or is our something more fundamental in the CE build ? that is the question…

Have you checked that the “Minimum samba version” is set to the same on all devices? Could it be that your CE is using smbv2 or v3, whereas the other devices might use smbv1?

If I remember correctly, only smbv1 has support for browsing. However, for security reasons, you should not use smbv1 anymore.

Yes… all set the same …


The point of using zeroconfig is that it has simply worked for me - where I previously had exactly the same issue as yourself with the latest versions of CE/LE. Give it a try.

You can spend a lot of time getting SMB to work between different systems - and sometimes a fix that simply sidesteps the issue is the best solution. Samba has been consistently flakey on just about every Linux system I have ever used.


Thanks Shoog …but I have it working via NFS and adding a network location by quoting the UNC … zeroconf May well work but it’s not the specific issue here …it looks like it’s the actual browsing that isn’t right from CE itself…

Essentially the other options give a workaround to SMB not working properly but they shouldn’t have to…

Browsing network shares is not a functionality of Samba since V2, so Network browsing cannot work if you are using anything other than SMB V1. Using a direct link to the share is how it is meant to work.


so you are saying that the Kodi on android is using V1 and Kodi on CE is using V2 or V3 … but even if I change CE Kodi to use V1 it still doesnt work …

I fear we are going round in circles my friend :smiley: … trying to remember a long UNC string (in my case there are about 6 subdirectories to get to my media) isn’t intuitive when a simple Browse through the Workgroup directory structure should work…

There is an inconsistency here between the 2 releases that I think is wrong is what I am saying …CE Kodi ought to work the same way as Android Kodi … no??

You are absolutely mistaken - browsing Samba shares was removed as a feature in Linux and in Windows. It has been discussed at length repeatedly on these forums. I told you the simple solution of how to navigate to your samba shares using zeroconfig (which is an option within the add source feature of Coreelec file browser which makes it as simple as browsing to the share) but if you don’t want to try it you will not get any other more useful suggestions.

"“The “Network Browse” function has been disabled on Windows 10 v1709 and higher.
SMB 1.0/CIFS File Sharing Support has been disabled on Windows 10 Windows 10 Fall Creators Update version 1709 and higher.
For more details, please refer to Microsoft Article SMBv1 is not installed by default in Windows 10 Fall Creators Update and Windows Server, version 1709"”

Linux has followed this Microsoft decision to the letter and disabled Samba share browsing in all versions of SMB above V2, but as you have also found share do not even work in most implementations of SMBv1 within Linux.

As I said before SMB has always been a mess within Linux, but you are wrong in assuming that Android is correct and CE is wrong - since Android is a highly bastardized and none standard version of Linux. You are either going to have to go with what works or torture yourself trying to work out why it doesn’t work for you.


Thanks Shoog.

I hear you but my observations aren’t based on Win10 or full blown Linux.

My observations were using an Android based system and Kodi 17.6 that you can browse to an SMB share by following down the directory tree … i have no idea if that is using V1 , V2 or V3 … they are all enabled afaik.

If I fire up CE that SMB browsing doesn’t work .

If the difference is what you say it is then fine , that answers that question but please don’t doubt the behaviours I observed on this.

Thank you for your responses…

I am surprised that you missed that I fully acknowledged your observations about CE’s behavior - I simply pointed out that the conclusion you drew about that behavior were wrong.

CE works in this regard as it is designed to work and as Windows specifies modern implementations of SMB to work.


Apologies for the confusion.

So I go to use Zeroconf and I don’t see my cloud device…All i see is COREELEC (SAMBA) so nowhere to browse to.

So all I can do is type the full Server/sharename in to either the network location or the NFS option.

Based on the above are you expecting me to be able to see the various shares using Zeroconf? I don’t.

Only things that work are NFS and Network Location …

It works for local network shares and that is all I have experience of. Cloud shares are a whole other layer of software which is probably causing your issues. Within your own Network you have control over all aspects of SAMBA since both the server and client are local - on cloud shares you only have control over the client - half of the equation.
Unfortunately I can offer no more advise.


1 Like

This is a local network share on a WD Mycloud local storage device… so not quite ‘cloud’ in the strictest sense of it …

Anyway…it is what it is…


In an environment with different windows versions and different home Server versions I always had this problems caused from SMB Master Browser Service.
Workaroud is/was to install freeze on my Router and enabled SMBD and NMBD Service. Then you have to priorize the value from the Master Browser Service to eg 128
Now this Service always will win the challenge in the local network to be the Master Browser for 24/7.
Then in kodi/CE set max SMB to value 2

Never again had the problem not to see devices via SMB

I’m kinda lost as to what your local SMB shares has to do with anything cloud.
For most, the two are entirely different.
I’m also a little confused as to why you are even considering the SMB path when NFS is working fine

The device is a Western Digital Mycoud box - essentially its just NAS. I’ve never thought of it as a ‘cloud’ like AWS etc that comment came from others.

Maybe i am being too pedantic here but go back to the original post and you will note i commented on the difference between Kodi on Android and the CE methods of finding exactly the same content … and i questioned why it works in 1 and not the other… it appears to have snowballedfrom there.

Yes i can get to my content via nfs or the network location but not as intuitively as SMB treats it …

Let’s close this out… I’ll deal with it… still not sure the way it works in CE is right though… :grin: