Solution: accessing SMB shares from Windows 10

Many people have trouble accessing SMB shares from Windows 10, whether its the SMB sharing of Coreelec or some other NAS device (for example in my WD MyCloud)

Most articles blame the diaabling of SMB v1 in Windows 10, but actually thats not the reason since Coreelec and most NAS already use v2 or 3 anyway.

The problem is faced when the SMB share doesnt have a password enabled. That is what Windows 10 disabled: accessing SMB shares that are not protected with password.

Obviously obe solution is to put passwords on SMB shares. The other is to enable password-less SMB access in Windows 10 settings.
These are located in 2 places and both have to be changed:

  1. In Group policy settings, theres a policy to enable something like allowing unprotected anonymous access or something like that
  2. In RegEdit the equivalent key also needs to be changed, sonething like LanMan…

Google search should help you find the exact names of the 2 settings to change, just i’m not on my PC currently, i’ll post them later if you cant find them.

  1. This is the Group policy that needs to be enabled:
    Computer configuration\administrative templates\network\Lanman Workstation
    “Enable insecure guest logons”

  2. And this is the registry entry that needs to be added:
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters]
    “AllowInsecureGuestAuth”=dword:1

As mentioned, these settings are needed for some users using Windows 10 and can’t access SMB shares (like CoreElec or NAS) because those shares are without password.

Warning: Strictly speaking the advise of security experts is to secure all SMB shares with password but if, like me, you have a closed system and/or you are confident about your firewall, then you should be fine without

This didnt work for me on an older version of CoreElec. I am in the process of updating my CoreElec install. I will let you know if that improves the situation.

I’ve never had a problem accessing SMB shares. In the case of MY_USER users on Windows machines MY_W10MACHINE with password MY_PASSWORD try the following combinations:

MY_USER - MY_PASSWORD
MY_W10MACHINE\MY_USER - MY_PASSWORD
MY_W10MACHINE/MY_USER - MY_PASSWORD

Note.- Never use shares without password!

After i have install wsdd2 via entware, i see my shares via windows.
at first i have install entware in shell via
installentware
and after question reboot i enter n.
after that i install wsdd2 via
/storage/.opt/bin/opkg install wsdd2
and than there comes a
reboot
Now i see my shares in Windows

About | FAQ | Terms of Service | Privacy Policy | Legal Notice