[SOLVED] A95X MAX S905X2 cannot boot CE

I’m not able to boot with new nightly builds. It just keeps rebooting at A95X logo.
Any advice please?

it happened to have same issue at stable builds with CE written with rufus. Then i tryied with etcher and finally booted fine :wink:

Installed the latest nightly build, but the audio volume is too low. Is there a way to increase the sound vol.

Thanx was easy as pie…Was getting corrupt file system until I used GPT Partition table.
(Does boot in MBR but once booted into android would get corrupted – FIXED – THANX)

HI all,

first of all, BIG THANKS to @Compent, his procedure works like a charme. I’ve modified some steps since I’m using a Linux Machine as PC so GPARTED and GDISK helped me to complete SSD partition.

About remote control, assuming that I’ve A95MAX where should be placed files to enable control? (.config!, but It does not work)

Last question,

Where can I post a question about PLEX and Acestream support (missing in COREELEC)?

THANKS! and have a GREAT 2020!

Not on this forum.

4 posts were merged into an existing topic: A95x max v81 dead

Since I’m experiencing the problem with the stable build, can you please explain your solution?


If you are referring to how to use etcher there are plenty of video tutorials on YouTube.

It’s very easy/

And if you are looking for here to download the stable build for the S905X2 then go here

Worked as a charm for me…

I have an A95X Max Board v.81 with unknot drivers for lan and Bluetooth… so those are not working… Wifi does work here and seems to be stable…

I managed to run this from Ssd drive… Managed to reboot to Coreelec from android and back…
Only thing left to me… is display works and showing clock… but no other functions then that… ooh and boot…

kind regards…

Great stuff.

I picked up a cheap generic dongle to provide bluetooth.

I only went as far as wanting the clock on the VFD, so can’t comment on any other functionality I’m afraid.

I have it working… showing all digits as should…

i forgot one step : Install OpenVFD Service via the CoreELEC repository in Kodi

after i did that all is working perfect… Except the bluetooth and lan… but wifi works fine… ))

hey all,

someone has been able toove to kodi 19 on this device?


Yes it works fine and this box is in daily use for me.

Thank you Compent.

Can you share any suggestion to move from 18 to 19 on this device?

Any feedback is really welcome


Generally you can simply apply the latest update .tar file and it should work fine.

But it is worth while running a backup so that you can go back if you need to and then consider a fresh install.

You will likely find that if all goes well then when you try to shut down, the box will reboot instead.

This is because of the DTB file, that requires an older version but let me know if this does happen and I’ll post an easy solution for you.


I will try and share the result.

Have a nice day!

Same as @Compent I’m still using my A95X Max running CoreELEC on a daily basis.
Because quite a few add-ons and skins are either not compatible with v19 or need updated versions I decided to do a clean install of 19.2 rc3. As expected I found my A95X Max then rebooted when it should shutdown. As I’ve done with previous versions I replaced the 19.2 rc3 dtb.img file with the one from CoreELEC 9.2.2 and that restored the shutdown function back to normal. I used the Transparency skin on previous CoreELEC and Kodi versions but this is one of the skins which has not been updated for v19. I tried all the ones that are v19 compatible and settled on Metropolis which for me is a great replacement for Transparency.


HI all,

I’ve simply put a stable version on Update folder and update. Probably is not the best way to do but no problem experienced.

I must install many addons that do not work in the new version, before be sure that anything works fine.

on the new version an issue experienced in the past version is still present: when I decide to switch off kodi it simply restart but does not switch off.

Any suggestion?

(it’s a minor issue, i do not care really)

REGARDS and thanks to @Compent for his support!

Firstly you will need the right DTB file, which you can get here.

Then you need to SSH into the box (I use WinSCP with the graphical interface)

There is more than one way to achieve things but the quickest for me is to navigate to root and then open up the flash directory.

Then open up a terminal and enter the command mount -o remount,rw /flash
Then copy the downloaded DTB to the flash directory, which will automatically overwrite the existing one.
Then reboot (type reboot in terminal or from the CE GUI or your TV/monitor)…

Note that every time you update CE you will need to run the same process.

I created a little script to make it easier for me as I always use the nighties, so do it regularly.