[SOLVED] A95X MAX S905X2 cannot boot CE

And…IT WORKS! well done chaps :+1:
I used the device tree for ‘s905x2 4g’ the one for ‘4g with 1g network’ didn’t work (even though it has 1gig network supposedly) but I’m using wireless so…
anyway, never say never @Pelican :stuck_out_tongue_winking_eye:
I knew the bootloader wasn’t locked all along :crazy_face:

1 Like

I am a bit lost.
I wrote the last nightly build (CoreELEC-Amlogic-ng.arm-9.1-nightly_20190824-Generic.img.gz which contains the updated cfgload if I am not mistaken) to my USB.
I also added the dummy.zip to the USB and I renamed the s905x2 4g dtb to dtb.img and moved to the root of the COREELEC partition.
After that I plugged in the USB and from the Android I started a manual update with the dummy.zip
I arrived into a menu where I could switch between boot into system or boot into bootloader but it just simply did not work. (With the boot into system option it booted to the Android system, with the boot into bootloader option it got stuck with the A95X Max logo).
Do I have to flash the box with atvX_v3A_A95XMAX.img before doing these or I am good with the original Android? What I am doing wrong? I also tried out with several USB ports.

Thanks for your help’

dunno what this dummy.zip is!!!???
I took the cfgload file from the cfgload.tar.gz file that pelican posted, the one in folder number 2…
I think I’ve since hosed by box messing around with copying libreelec to the mmc then overwriting the dtb.img with the wrong file :sob: That’s what happens when you try to be a smart ass but hey it booted really fast when using the internal mmc :stuck_out_tongue_closed_eyes:

Dummy.zip is an empty zip file which you can use to enforce the box to boot coreelec.
So how did you manage to restart the box and start with coreelec?

‘toothpick method’ or in my case stick a skinny screwdriver in the AV port, depress the reset button, power cord in, hold the reset button for 10 seconds or so, chocks away!!!

When I did this I arrived into a menu with black background and white menu elements. What should I do from here?

not sure what that is…post a pic…
with mine I got the A95X boot splash briefly then after a few more seconds the coreelec logo came up…the new horny one with the red design…then it just loads kodi…
I should add that the ‘toothpick method’ only needs to be done for the first boot, after that it just boots from the usb drive…

Not exactly like this, because mine is A95X MAX, but something like this.

From your picture it looks like you have Rockchip and not Amlogic box… This is a reason

This is why I explicitly stated that mine does not look like exactly like this, because mine is an A95X MAX B not a rockchip

check in android in AIDA and make a correct screenshot in android and from recovery…
I didn’t find any MAX B version in google… something is different in your box… need to understand what

This is how it looks like

What should I do?
This is the Aida for the box.

You should read this thread more closely, there’s a post with an updated cfgload file to make CE work on A95X boxes.

I am using the 2019 08 24 ng coreelec which already contains the updated cfgload.
based on the changelog:

e451c73b2a: Sat Aug 24 22:00:14 2019 +0200 - cfgload: fix loading of CoreELEC kernel (Portisch)

I also tried manually overwriting the cfgload based on @Pelican post, but with no luck.

  1. try different SD card or different brand sd card
  2. try via reset button again
  3. try also reboot update from android terminal if step 2 doesn’t work on new sd card also…


  1. I am using USB, not SD card. The USB drive does not have any problem, because I just booted CE on a different S905X2 box with the same USB drive (with different dtb.img though)
  2. The reset button located in the AV, right?

It says Rockchip A95x R2 8189.
How do you know if it is not a RK3328 box?
I would open it and check what is inside…

Now that CE will run on this box, I wonder if anybody using it can confirm that a drive connected to the internal bay can be seen by CE and if so, with the SATA interface being tied to the USB controller, would this enable CE to be run from a HDD/SSD?