[SOLVED] Coreelec not boot Odroid c2 with Emmc module


I have written the CoreELEC-Odroid_C2.arm-8.95.0.img.gz image in the 8 GB Emmc module of my Odroid c2 with Etcher
It does not start, it does not do anything, I have tried several times and it does not start.
I write that same image on an SD card and it works correctly.

Is Coreelec compatible with Emmc modules?


Yes it’s working fine on my emmc 32gb.
How dis you flash your emmc?

I have flashed the image with Etcher

Works fine on my 8gb emmc, flashed with libreelec tool (ironically) :slight_smile:

1 Like

What colour is the emmc module?

It’s red, bought on Ameridroid

This one?

This one

That should be fine


I have written the image with the Libreelec tool (thanks Zenji2010) and everything works fine.

Thank you all.

1 Like

Hi, i have green emmc. Can i install coreelec? i run rufus and flash coreelec but odroid c2 not booting.

@dimi256 I can flash the last release of CoreELEC to an eMMC and boot without issue.

Which exact file are you trying to flash?

Are you using the microsd eMMC adapter or the USB 3.0 eMMC module writer?

What do you mean by not booting? Absolutely nothing happens or starts to boot but fails at some point?

CoreELEC resizes it’s partitions on first boot then restarts, sometimes it doesn’t automatically power back up after this and needs to be unpluged and pluged back in to get it to continue. (This is only with the first boot, that this happens)

I use CoreELEC-S905.arm-8.95.6-S905.img.gz
141 MB And microsd emmc adapter And Green emmc. Absolutely nothing happens.


That’s the wrong file for installing on the C2. You need to use the CoreELEC-S905.arm-8.95.6-Odroid_C2.img.gz file instead.

I had the same problem today, after my libreelec upgrade.
Turns out, coreelec will not boot from emmc on c2 if you have a sd card inserted - it just shows the logo and goes into a black screen, with leds indicating normal boot.
Tried stable and dev - both behave the same. This didn’t happen in libreelec.

Does it work with a clean install, as the guides suggest ?

@6thsurvivor this is by design and not a bug after we changed the boot priority, if you have had LE/CE on the sdcard previously then you will have to erase the bootloader from the sdcard.

Thank you! Didn’t find any info about that, but it sounds lika a smart choice.
I had a backup install (in case of emmc failure or a config brainfart on my side) on the sd so it backfired.
I can confirm it’s working now (after neutering the bootloader)

The info is in the guides; the process of retrying, using a clean install, after encountering an issue, as advised, will wipe the SDcard (and therefore erase the bootloader) :thinking:

It was a clean eMMC install - I didn’t find anything in the lines of:

  • We’ve reverted from the previously supported boot option with 2 valid bootable devices - if you want to boot from emmc, make sure your SD is not bootable.

Since it was a clean install (it doesn’t mention to eject the sd card - remember we’re talking about the C2 here.
Since people are having problems - maybe the install instructions should explicitly cover this case?