[SOLVED] Garbage playback after upgrade to 9.0+

#1

After upgrade to 9.0 many video files show yellow-green garbage instead of proper video. Audio is OK.
The problen is for sure with VOB and WMV, some AVI are also broken.
MKV is played fine.

All these files were played fine in 8.0+ version of Coreelec

My HW is Manix TX3 Max

#2

Tanix TX3 Max Amlogic S905W 2GB/16GB ???
CE 9.0.1 Was released back in February 27
Can you fill in the gaps on what you’ve been using and what you are using now.
CE 8.0+ and upgrade to 9.0 helps no one understand what you’ve been up to.
Garbage is not a technical term to describe your issues.
Garbage can however be used to describe the hardware you have purchased.

2 Likes
#3

There were never any 8.0 CoreELEC builds. Other than that I have nothing to say about this because if this is suppose to be a bugreport it is pretty useless.

#4

If this is garbage HW, why are you developing for it? Not mentioning the fact, that everything has worked flawlessly before upgrading from 8.9.x builds to 9.0.x
I didn’t noticed it right away as I mainly watch mkv and they still work.
However, when I was trying to playback various WMV and VOB files that for sure worked in 8.9.x build, I’ve got yellow-green stripes instead of proper video. Audio is fine.

If needed, I can post detailed codec info for the files that are not played back properly

ps of course, I own Tanix, not Manix

#5

In Settings --> System --> CoreELEC (need to select Expert) --> Turn on “Disable deinterlace” toggle.
We support the whole S905* line, because the SoCs are similar, but the S905W in particular is inferior to everything else available. One of the reasons is this issue.

#6

Maybe try reading here

#7

Unfortunately, the proposed solution didn’t work

I’ve recorded the issue I have:

This is VOB playback

#8

SSH into your box.

Play the movie file for a few seconds.
Issue command below.
Copy the url result and post it back here.

dispinfo

#9

http://ix.io/1Iq8

#10

any clues?

#11

Change your HDMI cable and see if that helps :slight_smile:

#12

it won’t because the problem is with one type of files only

#13

Please upload some short examples somewhere to test them

#14

At least disable force422 and enable limit 8bit in Settings --> System --> CoreELEC as it seems that your AVR doesn’t support 422 and since it’s almost 10 years, 10bit 4K is probably not supported.

Upload some samples and we will look into it

#15

That solved the issue. Many, many thanks!