[Solved] Mecool M8S Pro+ not working


#1

I have just done a fresh installation of 8.99.2. After initial installation, I copied the relevant files from the remote thread to the correct destination folders and rebooted.

The remote sends the signal but has no effect. I have a spare remote and that doesn’t work either. Lost as to what to do next short of starting from scratch and making my own config.


#2

Make sure you copy the dtb for your device from the device_trees folder and not one from elsewhere on the internet.

Also enter the following command via SSH.

echo "meson-ir * mecool" > /storage/.config/rc_maps.cfg

That is all you need to do for mecool devices, you do not have to copy any files, reboot after that and it should work.


#3

Thanks so much for your quick reply. I removed the remote files I previously added, entered the above command, rebooted and ‘Hey Presto’, it worked!

Did I miss something in the remote thread because I didn’t pick up that entering the command was all I needed to do to get a Mecool remote recognized? Anyway, all fixed now. :grinning: