[SOLVED] MECOOL M8S Pro W won't boot. Straight to TWRP

Hi there !!

My MECOOL M8S Pro W won’t boot to CoreElec. It goes straight to TWRP. I am using a USB Drive, not an SD card. I have tried both USB ports.

I used the correct DTB file (gxl_p281_2g.dtb) as dtb.img.

Any help please ??

I forgot to mention that I have Nexus ATV installed, from Freaktab.

[ROM] Mecool M8S PRO W TVStock Nexus ROM (Android TV 7.1)

Just curious. Does your device come with TWRP or did you install it?

I don’t know if this will have or not. However, I always try to first perform a factory reset when the 1st time I configure my device to boot CE.

It was installed with the ROM that I installed, the one from FreakTab.

That sounded like you have flashed your unit with a 3rd party ROM? I don’t know if any 3rd party ROM comes with its u-boot environments (different from the stock). Anyway, I am no expert in this matter. However, I would try the following if I were you:

  1. Try using the SD slot with an SD card to see if that will work.
  2. If the above does not work, try with other DTB file.
  3. If that still does not work, re-install the original ROM to see if that will work.

Mine boots fine when I use the SD card slot. I think that the first time I had to keep pressing the menu button before it booted to CoreELEC.

It worked !!! From SD. Now to find a way for the remote to work !!!

Done… Used this method.

Does wifi work in your device? I ask because of this post of mine:

Thank you

Hooray!! :clap: :clap: Another Frankenstein installation is born. :face_with_raised_eyebrow:

About | FAQ | Terms of Service | Privacy Policy | Legal Notice