[SOLVED] N2 CoreELEC 9.2.0 and LG Nano-Cell SM9010 = still no HDMI-CEC?

Hello. Had problems since forever with CEC. Actually I never used it, as it never worked. Not with my previous x86_64 devices, not with the Cubox I4 Pro (running GeexBox, OpenELEC, LibreELEC and such) and two different Samsung TVs. Not with N2 (development nightly CoreELEC) and the latest Samsung TV I just replaced. I just got some annoying behavior where nothing worked on the remotes, but the TVs were randomly starting after being shut down. So had to disable everything to get some sleep, blamed Samsung and swore to never buy one.

And now it seems I can’t get CEC to work with N2 and my new LG SmartTV… and this one literally does nothing. But after all this time and hardware and software I am really sick of using 3 remotes.

The stack:

  • Odroid N2 4GB;
  • CoreELEC 9.2.0 playing stuff from a FreeNAS, via SMB;
  • 2019 LG 55" Nano-Cell SM9010PLA - great device with a great remote;
  • no AVR in between, as I am using my Yamaha in another room;
  • and yes, changed the HDMI cable with another one; like the most expensive one with a big CEC logo (SIC).

Now: in Input devices CEC is enabled on the N2. On the LG TV too (SIMPLINK), tried even the so called “Device connector” with different players (which makes no sense), but set for “Another box” as per their documentation. Reset everything multiple times. I just need the volume, play pause, and the directional/selecting stuff to work. Not interested in shutting down anything, my N2 is always up, so just hope to control Kodi from the LG TV MR19 remote.

Can someone give me some noob advices on how to get this shit to work? Really, I am at the end of my patience and something will get kicked out of the window :slight_smile: 10 years is too much sir, too much.

Hmm… That’s strange…
My N2s are connected to 3 different LG Smart TVs; SJ850, SK8500, and C8. And all CEC works.
All you need to do is turn on CEC (SIMPLINK) on the LG TV.
No need to do anything else, just 1 setting to turn on.
Did you turn off “Auto Power Sync” setting? Try to turn it on…
https://i.imgur.com/safR0hC.jpg

Try pressing the “CEC button” on the magic remote. It’s below number 9, next to number 0.
It’ll show the connected CEC device name on the screen…
https://i.imgur.com/t5GQ4u4.jpg

My 2017 60SJ82 series and my 2018 60UK62 series tvs work without any problem.
The CEC works even through my Denon AVR X2600 receiver.

Well - this is a known rule for me: as soon as I post some problem, I get things kinda working. Maybe my inner self needs some perspective/verbalization/or such :slight_smile:

Took the day off and spent 3-4 hours with the damn thing. There are only those two options for SIMPLINK and obviously tried all combinations multiple times in the past.

But now I used the silly “Device connector” and tried some random options. I got some results by setting N2 as a Set-top box, and a local TV provider, DIGI… I just don’t get it. All this AI and “simple” nonsensical options that don’t work. Until you try them all and find a random preset - that… kinda.

Now: it is weird, I know what you are talking about - but in that menu there are some player functions that do not work. Only the power option does. And no info about the device… It resembles yours but it shows in the right upper corner as text. Probably TV set specific.

Also: the Play/Pause buttons do not work on the remote, which is a pain. And not in the menu as I mentioned. Only way to play/pause is clicking the wheel and navigate the hell out of Kodi’s interface…

How did you start yours going? Is there another device that I should try for better compatibility? Did you do something special or was it more like for @Pelican ?

Later edit: when you press the volume buttons, which device do they control in your case? For me it is the standard TV volume.

Really the final edit: does the remote pointer work for you by any chance? In Kodi, as a mouse? :face_with_monocle:

I connected my N2s directly to the TV, no AVR in between. N2 is on HDMI1 input. AVR is on HDMI2 ARC input.

AFAIK, “Device connector” is for setting your remote as a universal remote and it will use it’s IR to control another decice, not CEC. You can use this with the combination of Keymap Editor plugin in Kodi to map most of your magic remote buttons with IR.
Some info: https://forum.kodi.tv/showthread.php?tid=304812

Your “CEC Menu” might be different from mine because you set up the “Device connector” and i didn’t.
I didn’t turn on the “Device connector” at all.

I only use CEC, and the only buttons that works are: volume, mute, power, navigation, enter, back, and the 4 colored buttons. I use Keymap Editor to map the 4 colored buttons.
It’s context aware too, so you can set different actions on the same button, when the screen is on kodi global menu or on fullscreen movie.

Oh, when i press the volume or mute buttons, it controls my AVR that’s on HDMI2 ARC input. It’s pretty smart :wink:

No, magic remote pointer will not work on anything besides the TV menu.

Do not use device connector because it will use IR to control your box instead of CEC.
The volume buttons on your magic remote controls your tv or your avr according to your audio out settings (tv speaker or HDMI out). The magic remote pointer is working on your tv only.

So in fact CEC is still not working - LoL… I will remove my USB IR receiver from the N2 to test this myself. You know IT DID FEEL LIKE IR, the lag I mean; so I was rather… huh, is this transferred via HDMI?

The problem remains - this was the only way I saw something (anything?) happening. I didn’t use the device connector at all, until now.

What else can I do? SIMPLINK is on, turned it off and on multiple times, even unplugged both the N2 and the TV from the outlet and did all the stupid things I could think of.

Love editing posts: how come that it is able to ask me that the device is off, and if it should start it? And once I CLICK on “Yes” it starts up the N2??? No IR there I think?

Have you tried to use another HDMI cable?
CEC uses a dedicated pin on the connector.

Yes, I had two different brands, bought a third braided one, gold plated etc.

I am thinking to buy another one just to be sure, will look for HDMI 2.0, maybe 2.1 if they are available.

It was IR, thanks for helping me.
Ordered 2 x https://www.delock.com/produkte/G_85727/merkmale.html?setLanguage=en And I will post back, if it works or not.

But by what magic can the TV start a device, when obviously I do not push any button on the remote?

HDMI CEC magic :wink:

We just established that HDMI-CEC is the black magic we strive for; but still out of reach. Have. To. Train. Harder.

Which version are you using? Stable or nightly?
Because I think I too have issue with last few nightlies…

Stable 9.2.0

CEC works partially on my N2 with CoreELEC 9.2.0 Stable.

Navigation, Return, and OK buttons on my TV remote works, but NOT Play, Pause, Skip, and Stop buttons. I have ruled out TV (Panasonic) and HDMI cable being the problem as CEC is fully functional on Vero 4K with the same TV and HDMI cable (all buttons work).

Not sure if it is a bug in CoreELEC or the default configuration is erroneous. How do you map color buttons for HDMI-CEC (not IR remote) anyway?

You need to debug CEC (enable debug), then see in log, what buttons are avaible for you by just pressing them (usually, device with kodi will not recognize all of the, some will be taken by TV instead Kodi). After you will know, what buttons you have available, you can map those freely by remote.xml. You need to google remote.xml and make some study about how you do that, but there are pretty nice tutorials around I believe.

P.S.: CEC-compatibility with pulse8 used by ELEC differes even with same brand of TV, with a few months delay between models. You cant be sure, every TV needs to be inspected and tuned… For me, I have two SAME remotes to the Phillips, with different compatibility, so I must for example map DELETE/CONTEXT MENU/PAGE UP/DOWN etc. actions to different buttons :slight_smile:

Keymap editor add-on is easier to use.

I got the new cables - the same old sad story: CEC is not working, had a few tries. Will get back to it when I have the time.

Very good news about this issue of mine - now it works. I think there were two separate problems:

  • the cables: at first nothing happened with the new HDMI 2.1 cable. But after I restarted both N2 and the TV it started working, That was short lived though: as soon as the TV stopped due to idle power settings - CEC was gone. I mean really gone, it didn’t work again despite all my efforts.
  • in the mean time I ordered from my cable provider a CI+ card to replace the old box, and as soon as I got it and setup the TV, I swear by the old gods: I switched to the N2 CoreELEC input and what do you know? CEC was working again and it was rock solid for a day now! I guess something got reseted in the TV or the box was simply breaking CEC somehow (don’t know if it is possible, they were hooked to different HDMI inputs?).

I am once again in love with this setup; have to look how to map some remote buttons (the play and pause do the same thing, so I want the pause one to actually stop the movie).

Thanks for all the help and patience!

Yes, it’s not uncommon for STBs and other CEC devices to conflict with others. Or just misbehave in general.