[SOLVED] No picture in 4k


I have a H96+ pro with a fresh install on Openelec on it.

If I connect the device directly to my amp I can get 4k 30fps but then I get no HDR as my amp doesn’t support it.

If I connect the device directly to my Samsung Q8 TV I can only get 1080p.
If I change the resolution to anything above that then I lose the picture, I wait for a few mins and it resets back to 1080p.

This is on the menu or if I play a 4k film.

Any ideas?

I’ve got another box running Librelec and that works fine in the same setup but it’s an older box with no HDR support.

Any guidance would be appreciated

Look in CoreELEC settings menu at the 422 video options and try that.

Cheers, I’ll try that but not convinced a colour correction will fix a no signal issue when smchanging to 4k resolution.

If that doesn’t work then it will be your cable, a quick search of the forum and you will see that many users report similar issues and it is usually solved with 1 or the other.

I’ve tried a couple of cables and had the same issue. Also, if I move the same cable and plug it in via my AVR I get the 4k picture (but no HDR due to the amp not supporting it).

I’ll buy a new cable and try change the YUV settings as suggested and see what happens.

I’ll come back once I’ve got the cable.

Why don’t you try activating the YUV422 setting as a first step?
It was implemented for exactly this problem. If it doesn’t solve your problem, you can still buy a new HDMI cable.

Settings>System>CoreELEC>Use 4:2:2 colour subsampling

As relkai said try this before running out to buy a new cable.

Ok, so I reconnected it again and low and behold it worked fine. Gave me the 4k resolution albeit the only 23.98 or 24.00 refresh rate (is that correct?).

However, when I tried to turn on UHD colour I got the ‘no input’ signal again.

I changed the 422 setting as suggested and it still did the same and I tried changing to limit to 8bit colour and again both options in UHD colour resulted in ‘no input’ message on the TV until I turned it off.

This is in the openelec menu before I even try to play a movie.


In that case, it sounds like a bad cable.
Get a cable that is Premium High Speed certified.

Ok, so I’ve fiddled with it and if I set the resolution to 3840x2160p it gives me a full list of refresh rates and I can set it to 60. Then the UHD colour then works fine.

If I switch to 4096x2160p I only get 23.98 and 24.00 refresh rate and no UHD colour mode.

Any idea why this is?

That’s how it’s supposed to work, it’s probably a HDMI bandwidth/chipset limitation.
Either way, “4K” TVs aren’t really 4K, they’re UHD, which means their native resolution is 3840x2160, that’s the setting you should be using.

Brill. Cheers.

So that’s showing HDR nicely now.

What refresh rate should it be? It seems a touch jerky as it is.

You should set GUI to 1080P @ 60Hz or 50Hz. I use 50Hz, as I use IPTV which is 25FPS, so there’s no need for refresh rate changes every time I play\stop a channel.
When you play 4K content, the refresh rate should match the content.
24Hz for 24FPS content, 50Hz for 25/50FPS and 60Hz for 30/60FPS.

I strongly recommend you read this thread:

Will do.

All the help as really been appreciated.

Cheers all. Case closed!

Same issue here, can only get 4k working by setting resolution to 4096x2160 or 3840x2160 and turning on 4.2.2 colour subsampling toggle. If I set it to 1080p as suggested it doesn’t work and I get no signal.

I can have it at 1080p and turn the limit display depth to 8bit and it seems to work correctly but of course it’s not 10bit.

Everything else results in no signal.

Hi community,
i’ve noiticed the same issue with “no 4K picture” in Coreelec 9.03/Odroid N2. Unfortunately i can’t find the setting for turning on 4.2.2 colour subsampling toggle? Could you please give me a hint, where i can find this setting or what i am doing wrong?
Big thanks in advance

Options>System>CoreELEC>Use 4:2:2 colour subsampling

You have to set your skin to Expert-mode, I think…

1 Like

Hi pepeq,
thanks for your reply. Hmmh, it seems, that there isn’t such a setting here :thinking:

It available in nightly builds

1 Like