[Solved] Odroid N2 Ethernet Speed Problem

Hi all, a couple of days ago I changed my router. Old and new one have 1Gbits Ethernet ports.
Now with new router, when I power on (or reboot) my N2 (CE 19.3 stable) I see that Ethernet orange Led is lit all the time, signalling only 100 Mbits link. Checking via sh I get:
100.txt (1.4 KB)

Then, if I just disconnect Ethernet cable and reconnect it orange Led stays off an the speed is back to normal 1Gbits:
1000.txt (1.5 KB)

Reverting to old router is no option, so to fix this behaviour is this a good way?:
Fix ethernet speed-N2.txt (446 Bytes)

Or is there a simpler way to fix this?

Ethernet connections on my PC and ZgemmaH7 Sat Box work with 1Gbits as before connected to new router, only N2 has this problem; changing router ports and cables does not solve this problem.

This normally happens when the router has some sort of green or eco mode on that Ethernet port. Look in your router settings and nake sure the port is Gigabit capable.

No green/eco functions on this router (Speedport Smart 3 by Arcadyan). This is what router reports on LAN Status:

But N2 is connected only with 100 Mbits…

I had exactly the same issue, seemed to be a negotiation issue where it would only connect at 100mbps on boot but then work at 1gb when the cable was disconnected and reconnected.

I ended up changing the cable and it seemed to fix the issue.

I already tried with 3 different cables that work perfectly on my other devices, so i ruled out cable issue. In the mean time I did some further testing:
Booting CE 9.2.8 → only 100Mbits
Booting Android 9 → only 100Mbits
Changing the router with my spare Huawei B535 LTE with gigabit ports with same cable:
Booting CE 9.2.8 and 19.3 → 1000Mbits without any hiccups!

So it’s definitively some incompatibility between my N2 and Speedport Smart 3 router…

Checking with “# ethtool eth0” there is a difference in only one line:
Speedport router: Link partner advertised pause frame use: No
Huawei router: Link partner advertised pause frame use: Symmetric

Questions: What does this mean? How can I debug this, to try to fix it? Or it’s not fixable on N2 side?

You can try a switch
router <-> switch <-> N2 and other devices

Tnx, don’t have switch at hand, but my Mesh WiFi has a simple two port switch (LAN in LAN out); when connected to this Mesh WiFi I get:
Link partner advertised pause frame use: Symmetric Receive-only
Link partner advertised auto-negotiation: Yes
Link partner advertised FEC modes: Not reported
Speed: 1000Mb/s
Different when connected directly to router:
Speedport router: Link partner advertised pause frame use: No

So, this is one solution to rewire my permanent connections :slight_smile:

You can also try ethtool which is I think ibcluded in the network-tools addon. You can force a network speed there iirc. A simple cmd in autostart.sh could work here.

ethool is already on board, and I use it.
How to run this command “ethtool -s eth0 speed 1000 duplex full autoneg off” on boot? Just place it into “autostart.sh” ?

Edit: just did that, and problem solved. After reboot and power cycle everything is back to normal. Have again 1Gbit/s speed :grinning_face_with_smiling_eyes:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice