(Solved) Planet Earth II 4k

I have most of my recent troubles with the N2 fixed but I have this series that will only display a black screen with sound. Seems that my other 4k movies and series work. Any thoughts.
http://ix.io/1Yk2

This series works for me on 9.2 stable.

Planet Earth and Blue Planet will not display for me but the other series I have and 4k movies do display.
Not sure what settings I should mess with.
Thanks

I have the same problem. Reason is the 2160p@50Hz of Planet Earth II.

My N2 is connected via a Bose-AVR to my 4K-TV and the AVR cannot
handle 2160p@50HZ. A 2160p@30Hz-movie works.

If I connect my N2 directly to my LG-TV, then 2160p@50Hz works.

Workaround:
You can disable the 2160p@50Hz resolution in CE-settings (valid resolutions).
Then N2 scales a 2160p@50Hz movie to 1080p@50Hz.
You have to decide, if this makes sense for a 4K-movie…

My AVR (NAD 777v3) just passes through the video so I am not sure that it is the problem.

Ok I finally got this to work by white listing all the resolutions. Funny I had to do that since on my Minix u9 I did not have to input those. But fixed is all I care about

That means, same cables, same AVR, same TV, but with N2 2160po@50Hz does not work,
with Minix-U9 it works?

@adamg, @TheCoolest or other CES-supporter: what does this mean?

Let me check again for sure and report back.

From the dispinfo output, it seems that the HDMI input is not detected as HDMI 2.0 capable. 24P movies will switch into 24Hz mode, which is supported by the HDMI 1.4 spec. 25FPS content will make Kodi switch into 50FPS, which isn’t. I’d suggest looking in the AVR and/or TV manual, because some hardware requires HDMI 2.0 to be enabled manually on an HDMI input, be it an AVR or TV.

But why is there a difference if N2 or Minux-U9 is connected to the AVR?
That seems to me that the N2 handles a 2160p@50Hz in another (worse) way than a Minix-U9…

I don’t know why they behave differently, but they use two different kernel versions, and there are differences in the HDMI and other drivers.

So what solved the problem?

If you whitelist all resolutions on N2, is Planet Earth II then displayed in 2160p@50Hz
on your TV or is it scaled down to 1080p?

So I just check the Minix on a new install of stable 9.2 and it worked without adding anything to the white list. On the N2 I had to add all my resolutions to the white list for it to play. The N2 is running nightly’s if that is any help.

On the N2:
Do you say, the white list is empty by default and you add resolutions? Which one?
And after filling the white list the 2160p@50Hz movie is displayed on your TV as 2160p@50Hz?

White list is empty by default. Need to highlight the resolution and hit ok. This then fills the white list box.

This is going to my projector with a fiber HDMI cable and yes adding the 2160@50Hz will indeed display after adding to white list

My chain is N2 (fiber HDMI) to AVR (fiber HDMI) to projector.

here is the display info from Minix playing that same show.
http://ix.io/1Ym7

It plays back at 8-bit 4:2:0 instead of 10-bit 4:2:0.
In OP, it also seems that you have force 4:2:2 enabled on the N2.

it may do that on the Minix but on the N2 it will not display at all without setting the white list. On the N2 I also have the force to 8 bit and HDR-SDR (auto) SDR-HDR (off)

Let me load the N2 back up and try it again on default settings.