[SOLVED] R-TV S10 Install help

I own the tv box in the subject, it’s an S912 with fake RAM (2 out of 3GB) and locked bootloader.
It’s actually possible to have the board boot other OSes other than the built in Android, but I’d like to use CoreELEC.

I’ve tried any of the available dtb’s, but I’ve never been able to boot, always black screen or stuck on S10 logo. I’ve seen that others have had the same problem, and the few success stories seem to have a device with a different (unlocked) bootloader.

So I’d like to request any advice or suggestion of how to get the box to successfully boot into CoreELEC.

I’m afraid that with a locked bootloader there is no way to install/run other OS on your box.
The solution would be to find and flash an Android version for your box which does not have locked bootloader, but that is sometimes not an easy task…

As I’ve written it’s actually possible to boot other OSes, I’ve been able to use Armbian and some LibreELEC builds.

I have an R-TV S10 with 2Gb RAM, so the only 2 dtb’s that should work are gxm_q201_2g_1gbit and gxm_q201_3g_1gbit

I always used to use the USB port to boot CE and don’t recall using the SD card and if you do use a USB port it has to be a specific one, which from memory is the rear right one.

If you do have fake RAM then it does indicate a fake box that could well have different specs elsewhere inside too, so you may end up having to try all the various dtb’s or crack open the box to see what is on your particular board.

I’ve run from internal storage for a while now, so not had to boot from any other source but if you find that you are unable to get yours to use CE then I can double check what external boot options work.

I also seem to recall that Beelink GT1/Ultimate firmware was also compatible but initially I used a great generic S912 firmware produced by the user superceleron over at the Freaktab forums.

Here is a relevant thread regarding the locked bootloader in stock firmware.

Thanks for the help,
Box can boot Armbian from any USB ports/SD slot, so I didn’t think there would be such limitation.
So I gave another try with the USB port used for recovery but nothing changed.
Yes, this box has locked bootloader and the only other firmware that can be installed is the slightly modified one from the thread you linked, but I don’t care for Android.

If you have booted Armbian then you need to completely restore the device with USB Burning Tool, balbes images make changes to the bootloader that prevent CE from booting.

Didn’t know that.
Well, I went and restored Android, but CoreELEC still didn’t boot, moreover the test LibreELEC builds that used to work didn’t work anymore!

So it’s Armbian install that changes something and make it possible to bypass the locked bootloader, but at the same time it makes CoreELEC un-bootable.

How exactly did you restore Android?

Shorting 2 pins of the EMMC and using USB Burning tool.

Okay and now you have just tried to run the LE test builds again which are also made by balbes? You need to do it all over again, make sure you select erase all as well.

After restoring Android the LE test builds didn’t work.
I then booted Armbian (from android backup update) once, and after that the LE test builds booted.

That is your problem, you keep booting Armbian and LE test builds and your blocking yourself from running CE because of the changes both of those builds make.

I already said a few posts ago that CE won’t boot, even after an Android restore it still won’t boot.
I’ve tried the suggestions above, tested multiple dtb and usb ports, tried different ways to trigger a restart and nothing worked.

So I guess there’s no hope: The locked bootloader prevents this box from booting CE or other images, unless they are built using balbes’s bootloader.

Yes but then you said this in your most recent post.

The way balbes boots his images is slightly different to how we do it, he uses the uboot command booti where we use bootm and that is probably why his are booting for you, I have seen another device with the same problem in the past, I can probably make a different autoscript for you to try.

Ok, fair enough :wink:

You mean that changing the bootm into booti in aml_autoscript is enough?

Yes please! And could you also add a kernel command to limit the memory to 2GB?

Guess the other device is the one discussed in this thread:

I’ve downloaded the cfgload file and dropped into the usb and … Seems to boot CE!

So, replacing aml_autoscript with cfgload makes CoreELEC boot and seems to successfully complete installation to EMMC… But then when it reboots it crashes.

I’m not sure if the problem is in the aml_autoscript or in the installtointernal script.
Does anyone have any Ideas about that?

What tools are used to compress/decompress the u-boot script files?

When you ran installtoemmc, did you run it twice in succession before rebooting?

I thought the correct way was to reboot between the 2 installtonand, at least according to this

Anyway I’ve tried both ways and multiple times: The box simply crashes on reboot.
I’ve noticed the the env variable “bootfromnand=1” is present before rebooting and it’s gone after.

Maybe it would be better to boot from SD and set /storage to the internal EMMC, but to do that I need to edit the aml_autoscript.

Can someone please tell me how to decompress/compress the u-boot script files?

What exactly did you do here?

Took the cfgload from the post linked above, renamed aml_autoscript and placed into USB drive.
CoreELEC now boots.