[SOLVED] U-boot last version already built in latetst coreelec release?


#1

Hi

I’m using s912 h96 pro+ 3/32 device, running coreelec 8.95.7 release with Kodi v18 Leia (Release Candidate 4) and used gxm_q201_3g_1gbit.dtb as device tree.

after turning the device to shutdown, it won’t start anymore after pressing power on, only via remove power and reattach. I’m reading many pages about uboot but can’t find the answer yet how to resolve

meanwhile I’ve tried to change the sleep.conf parameters, it will let the device go into sleep modus. but awakening leads to returning the screen but nothing is working anymore, so i’ll remove the sleep.conf file and let the device go to power-off.

I found new u-boot files (v2.2. or 5.6) https://github.com/CoreELEC/u-boot/releases/tag/v0.1-alpha and can’t figure out how to upgrade that on the current SD card, withour disturbing the current 7.1.2 installed on internal memory. I’ve read something about \storage.update folder and but the .tar file in there? is that the best way to perform?

Does anyone knows if those u-boot files are already in the latetst coreelec release 8.95.7?


#2

The u boot that I know, Coreelec does not touch it, since that is a manufacturer’s thing.


#3

Thread for discussion on that u-boot can be found here.

We only package u-boot for developer boards.