"Successfully removed storage" - Coreelec/Storage Partition on SD Card


After successfuly installing Coreelec 8.99.2 on an micro SD Card (Kingston Canvas Go! - SDCG2/32GB) I experience the following issue:

I randomly get a pop-up notification saying “Successfully removed storage” and immediately afterwards “Successfully mounted storage”. Then the box soon becomes unresponsive and I need to force hard-reboot. Sometimes I can also navigate to the reboot button and perform soft-reboot in order to avoid a hard-reboot.

This happens out of the blue and not when the Amlogic 905X box (MyGica 495X) is idle. Also it appears that it does not necessarily happen under heavy load (e.g. when streaming HD content), as I was able to watch continously a couple of 1080p 60min-videos without any interruption at all. I have observed that it happens when navigating in Coreelec menus or in any addon menu. And it definitely happens every single time the box is working.

After reading through the web, I try to nail down the root of the issue:

  1. Could it be an insufficient power supply issue?

I rather doubt, otherwise I would expect the issue to be observed when watching high quality videos, when the temperature is high and the available resources lower. Anyway, I have ordered an adapter for my RPI’s (3 Amp) PSU in order to use the latter PSU and then am going to re-assess the issue.

  1. Could it be due to a faulty or incompatible micro SD issue?

I have tested another spare 2GB micro SD Card with Coreelec 8.99.2 and the issue is observed there too. Hence I assume that it is not an SDcard-related issue.

  1. Could it relate to Kodi/Coreelec/Libreelec itself?

Most likely I think. I have found at least 5-6 threads on the web with the same issue, but I can’t see this being resolved to anyone. It it not particularly related to certain devices as it happens to Linux, Libreelec on RPi, Openelec etc.

I tried to debug the issue via the debug logs stored on memory, but apart from the fact that it is quite difficult to pin-point the issue, it appears that the log is stopped/restarted because the card gets unmounted.

I did ran “dmesg” command via SSH before and after the issue happens and the output is in the attached logs.

I would appreciate any ideas or guidance to further resolve the issue.


Could it be a hw issue with the SDcard detection contact of the slot?
Sometimes card dimensions differ (within tolerances), giving a weak contact.
Or contact pins are bended due to production issue / excessive usage / insertion force

I had similar issues with a cheap usb to sata adapter. Solved by upgrading to a better adapter. Its either a power or contacts issue and definately not a CE issue.
It maybe a faulty socket. You can try running off a Usb stick and see if you get the same behaviour. You maybe can only get reliable operation if you run off nand.


To me it sounds like a faulty socket or something else is causing the connection to fail (momentarily).
Try Shoog’s suggestion to see if the behaviour improves

rho-bot, Shoog, Atreyu,

Many thanks for the guidance to check CE via USB on my device.

Apparently the issue does not exist anymore when using a USB stick; 5 hours of use without any error. To be honest, CE looks far more robust now via USB.

I could hardly believe that the microSD socket could be faulty (or just causing problems to the operation due to power or any other manufacturing reason), especially if I have only inserted a card not more than 10 times (!) during the entire life of the box. I did insert the card with care fyi…

Thanks again