Support added for S905X2, S922X and A311D!

No, it will not.

it need to add into kernel source, write to config and build zImage…

Ouch! But it’s for some technical reason or because you don’t want to add this command?

There’s a huge difference using CE from internal!

You can implement it and don’t give support to related problems, like you did in other builds

No developer will want to develop or implement something that can easily brick your box, so don’t ask for it.
With boxes on old kernel it was a different story…

I have the t95q which I connected to a Gigabit powerline ethernet adapter. Is there a way to test if the Ethernet on the device is working as a Gigabit or constrained to 100Mbps?

SSH into your box and type:-

ethtool eth0 | grep -i speed

1 Like

One more question. I have all audio to be passed through to my avr. But when I play audio with dolby truehd, my receiver just displays dolby digital. If I play something with DTS HD, it displays DTS HD MA. Does dolby true hd passthrough work on this build?

Yes, Dolby TrueHD works, check your audio settings.

If you experience huge difference then you can try to buy a faster SD card/pendrive.

I have already enabled everything in expert mode for dolby and dts. Will play around with different files.

Are you on latest nightly (07-22)?

Yes. This is what I downloaded last night.

Also I have 5.2.1 setup at the moment and I selected 7.1 in kodi. I believe the source video is dolby truehd 5.1.

Select 2.0 in audio settings,
I’ve just tried a couple of THD file and all of them works (N2 and VIM3).

Thanks for your help. Will give it a try once I get home and confirm.

You can find samples over here ( to test your setup. I’ve tested almost all of the samples and the only problematic are related to 3D MVC and LPCM. So you shouldn’t have any issues regarding DTS and Dolby.

Thanks @Pelican @CI6N0Z looks like my old bluray rips I thought has dolby true hd audio only had dolby digital. I tried test files downloaded from dolby website and all play well.

Only issues I have left now are the always on led light which I understand I have to live with and the issue playing 4k videos which looks like a known issue.

Hi, would you care to elaborate on that? I’m thinking that if that’s the case, there’s really no reason to spend money on boxes with larger rom memory, if you only plan to use it for CE, that is (like me).

Just received my MeCOOL KM9 Pro AndroidTV box (S905X2 2G/16G) and tested with Jul 24 build (the same 16GB SD card upgraded from Jul 22) using g12a_s905x2_2g.dtb.

Boot: OK
Ethernet: OK
Audio: OK
Remote: not OK
x265 10bit 1080p: Play flawlessly
x265 HDR 10bit 2160p: Play OK (checked on 720p TV though, not sure whether HDR color output is correct or not)
CEC: not OK (unlike the X96S TV stick, it reports CEC cannot be initialized!)

WiFi chip on the KM9 Pro is AP6236.

Edit: ‘Tone HDR color to SDR’ under CoreELEC setting is working. I now can get better color for HDR video on the TV.

You have to configure your remote, refer to the thread here.

Yeah, I know. Try to figure out any config file available. I haven’t had that IR remote before!

Edit: Upon update of remote config file, the IR remote is now working. I used M8SProW from repository compiled by bubblegum57. I can power off the TV box with the IR remote but not able to power it back on.