Support added for S905X2, S922X and A311D!

Did you try another HDMI cable and/or port on your TV?

yes, still the same. I will try on a different tv and report

Hi! Keep the great job!

Installed on a cheap tr99 x2 2+16 and it boots fine, and all works ok except wifi, it doesn’t have bluetooth.

The wifi chipset is a RTL8189ETV with only 2,4g band.

I attach a photo.

I tried X96MAX on 3 different TV, nameli LG Oled C8 using the same hdmi and hdmi port that I use normally for the Odroid N2.
Then on Panasonic GX 800 serie using the same hdmi cable and port that I usually use for the Mecool K1 Pro
Then on LG 8100 again using the same hdmi cabler and port I usually use for the Mecool M8S PRO L

Got the same problem with 4K Hdr. Those horizontal random coloured stripes.
I tried to use the Kodi player from Android in X96MAX and 4K Hdr works perfect apart the incorrect fps.

CEC worked just now - from cold boot where everything was turned off at the wall. I can’t think of anything that’s changed - could it be a timing issue, hence the hit and miss nature of it?

In android for hevc kodi use hw mediacodec but coreelec has amcodec…

Try to use hw mediacodec and disable amcodec for hevc/.h265 4K

You need the latest nightly for CEC as it was fixed in that release.

Please provide a sample of a file with the video issue you are having.

We have had issues with getting this wifi chipset to work on x96 max 2gb devices but you can try and let us know the results.

SSH to your device and try the following commands.

wget https://test.coreelec.org/8189es.ko
insmod ./8189es.ko

I salute you with great respect for your work.

Do you think CE also matches the H96Max 4/64? I found it on bangood with $ 40.

thanks

here are 2 samples video.

https://mega.nz/fm/BvRT1Daa

No links in your post?

sorry i’m not at home dealing with these things.

https://mega.nz/fm/BvRT1Daa
You find the original files and also how they look trough the X96Max.with all those strange horizontal coloured stripes.
Please note that the problem is common to all my 4K files (over 200 files Mkv and m2ts).
No one plays correct.

H96 or X96?

The box is X96Max 4g/32g

Hi, I got a t95q today which has Gigabit Ethernet. I am new to coreelec. Can you please let me now how to install a nightly build on this and what device tree to use?

I am fully aware that it may not work, but I would like to try and will report any issues here. Below is the device I have.

X96 Max 4/32 Coreelec nightly 22072019
amcodec hw
bd remux 4K hevc 2160/24p The Martian

You install nightly like you normally install CE: How to install CoreELEC
You need to use the S905X2_4g_1gbit DTB file.

1 Like

Yes, I know. What interesting, SPMC on android with amcodec play 4K the same, but mediacodec play perfect…

I have got the same problem with any 4K file Yes kodi in android plays without this problem