Support for new revision of Tox3 in NE

I have a new revision of Tox3 box with S905X4 rev. D, and while NG image works fine, NE image fails to boot - I tried both 20.1 (with either sc2_s905x4_ugoos_x4 or sc2_s905x4_4g_1gbit device trees) and nightly images (Nexus & Omega, all generic images) - in all of them all I get is a corrupted screen which looks like below. I saw other people that have Tox3 with this S905X4 revision reporting success using NE branch, though it is not clear if they also have the new revision of the box, or maybe they have the old revision which happened to have S905X4 rev. D. From people that opened their boxes I know that the new revision of the box changed WIFI chip to RLT8822 and replaced memory modules with some kind of Samsung chip.

Is there some information about addition of support for this revision of the box to the NE branch?

Try with Amlogic-ne, CE-21, Omega

I tried with Amlogic-ne CE-21 nightly 20230402 and got similar results, though the display looked differently corrupted (full screen instead of a quarter screen)

That happens to me quite often, and not just this device. I have to have the TV powered up, THEN power on the “device”. I guess it is some kind of handshake issue. When this happens, I pull the plug on the “device” and when I plug it back in, all is good.

So, try again with the Amlogic-ne , CE-21, Omega as Portisch suggest. That is the only version that will work with my “D” version of my TOX3 box.

This is my HK1 Rbox X4 doing the same thing, if I power it on before the TV.

Yes
EDID
Looks for/Identify a/v display

Order of operation on OS boot ?

Maybe???

Just turn TV and AVR on first!!!

Happy Testing

Or if turn TV on after
Change input/source on TV settings

HDMI input will respond to CoreELEC/read

As multiple times written before: the TV system MUST be available before the device boot up!
Otherwise the device have no info about what is connected to the HDMI and can not init the driver!

Best is to use the CEC wakeup, so the TV is on and wake up the device and everything is how it should be.

It seems that I found the source of the problem: I use PC monitor as an output, and tv box is connected to the monitor’s DVI input port via HDMI->DVI adapter. When I connect the box to another input port on the same monitor - a full HDMI, things work. So it seems that the problem is caused by the adapter.

Since NG works properly with this HDMI->DVI adapter, does it means that NE misses some driver and that the problem can be fixed in the future?

Screenshot of NE usage via the adapter:
pic

Dont use HDMI/DVI adapter with .ne

Use other input HDMI?

Maybe monitor settings in ASUS
Like auto config when using adapter .

Should not be driver issue in CoreELEC version?

Strange

I cannot use HDMI input since the display has only one such input and it is used by the main system. There are no display settings that configure those inputs.

My point though is not just to find a workaround for the problem (I could just use NG instead of NE), but to raise an awareness about the issue and as the result have it fixed, if possible.

Okay

Everyone setup is different

There has to be settings/buttons on Monitor
Enter OSD
Menu …

By default CoreELEC boots at 1920 x 1080
When i use ACER Monitor everything is shift to far left…

I cant access settings
So use auto config in Monitor settings menu
Then i still gave to position screen to the right.

Then can access CoreELEC menu
To change resolution
Then reboot
All is good
EDID remembers

Using Nexus .ng
As opposed to Nexus. ne

Not exactly a work around.

Both perform excellent!!

I have A95XF4 S905X4 BOX
With latest Nexus .ne
Booted on ACER Monitor

Happy Testing

Right now there is no significant difference between the branches, but NE will be supported much longer - upon release of NE, NG will become EOSD. Those tv boxes are long lived: I still have a S905X device which didn’t make it to NG, and I miss functionality of the newer versions. Therefore having device supported in NE is quite important.

I have a S905X with CE 20.1 installed on emmc, maybe yours is S905 simple. S905X its still supported. :neutral_face: coreelec:devgeneric [CoreELEC Wiki]

Well

Hope you get it going with adapter dvi

As posted latest Nexus 04 08 .ne

Boots on ACER Monitor

From your image posted looks like display is on forced landscape mode…

Or something…

Good luck

Happy Testing

Just received a Tox3. Nice build, cooler. Cannot make it to flash slimbox ATV ROM. It’s going into recovery. Also, the remote doesn’t work with CE ne 20 Nightly. edit: it’s working
CE Omega on SD card warns about missing partition…
I manage the situation with an Minix Lite remote with usb dongle. Edit: not working anymore :sweat_smile:
@clarkss12, please chime in, how did you manage to get the slimbox firmware? :thinking:

Not sure what you mean about going into recovery. You have to burn the ROM using the USB burning tool. Make sure you have the power plugged in. I forget off hand which sequence to plug in the power. But it will not burn that firmware without power connector to the box.

Tried that but no luck, the damn box stays in recovery. Pressing the reset button, plug the Y cable, plug in the power source, nada. It’s going straight to the recovery. And isn’t seen also in the Amlogic USB burning tool.

You must have your box connected to the TV in order to see the recovery menu…
To use the “img” firmware, you have to use the Amlogic USB Burning tool. I am using version 3.1.8 of the tool, (other versions may work also).

I open the tool, load the “img”, click “start”. Then I connect the USB male to male cable into my box and PC as the same time I am depressing the reset button (hole on the bottom of box). I then connect the power plug.

This box is tricky, took me a few tries to get it to burn the Slimbox firmware.

You may have to try connecting the power first, or any other way. Keep trying with the tool, it will work.

1 Like

Thanks for the input! I will try them all - maybe change the pc, the cable…Somehow, all the remote and vfd issue are gone. The box is cold when playing 4k rips, I could stay on the TOX3 Android, just for the bootloader, I use only the CE.

No matter what combination I’m trying, I got here.

Don’t know what to say. I am beat, will try next week to grab other cables… :roll_eyes: