Support for rtl8821CU wifi driver

Hi there,

I’ve got a Mecool M8S Pro+, which has the infamous 9082xs… So I decided to buy a wifi dongle for that device. I checked the topic regarding usb dongles and the RTL8811AU seemed to be a good option: Working USB Wifi/Ethernet adapters for CoreELEC

So I decided to buy this one from AE:

But the module seems to be a RTL8811CU instead of a RTL8811AU… So when I expected to have it working out-of-the-box, it didn’t happen… I was surprised when discovered that drivers seem to be compatible between them according to Realtek:
For Realtek USB WLAN Family Controller. The driver released on the website only supports the following products: RTL8812AU/RTL8811AU/RTL8192EU/RTL8812BU/RTL8811CU/RTL8814AU: WLAN-only solutions, install WLAN driver

Did a dmesg which gave me:
[ 4475.638832@3] usb 1-1: new high-speed USB device number 8 using xhci-hcd
[ 4475.779121@0] usb 1-1: New USB device found, idVendor=0bda, idProduct=c811
[ 4475.779134@0] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 4475.779139@0] usb 1-1: Product: 802.11ac NIC
[ 4475.779145@0] usb 1-1: Manufacturer: Realtek
[ 4475.779150@0] usb 1-1: SerialNumber: 123456

I’ve found some “source” code from a Github repository which claims to have obtained the drivers from the CD that comes with the dongle:

Can this driver be used with CE?

Thank you very much in advance!

PS: just found another source
PS2: and another one

Open a dispute with seller whilst waiting.
You’ll get at least a partial refund.
Sending stuff back to China is a real pain in the arse.
Customs forms etc.
At least the seller won’t sell these adapters with incorrectly advertised chips.

Well, I don’t really want a refund for the item. My question is about the possibility of compile those drivers for CE. Can it be done?

I successfully compiled this driver for LibreELEC with kernel 5.2 and it works fine. However, it does not compile with kernel 3.14 - I get build errors when trying to build it for CoreELEC amlogic-3.14.

1 Like

Looks like this driver has been updated and modified to compile for kernel 5.x, so it makes sense that it’s not compatible with 3.14.

Seems like the lowest kernel version that is supported by that driver is 4.4. At least it should be usable with amlogic kernel 4.9.

1 Like

I poked around a bit more with the driver and I found a way to make it build with kernel 3.14. It should work with RTL8811CU and RTL8821CU.


Good to see that!
We will tell if you know how to correct it.
KI Plus S905D has a Wi-Fi chip SCI s9082c

Amazing!!! How can I add this to my CoreElec?

I tested it with this adapter (RTL8811CU) on Le Potato.


I also included the SCI s9082c driver in that build. But it is totally untested.

1 Like

Many thanks!

I’ve tried in my Mecool M8S Pro+, but I couldn’t make it boot. Black screen…

Thanks for uploading the image file. It works on my nexbox s905 soc. Great job!

1 Like

It has been in nightly builds for a while now as well.

Driver from the nightly builds does not work. Maybe it works in kernel 4.9 N2 builds but not in kernel 3.14 builds.
In my build I used this driver and this hack to make it work with kernel 3.14.

1 Like

It works on my nexbox a95x S905 with kernel 3.14.29. I tried lots of ROMs and none of them works except the one you uploaded. Most of them only works with rtl8811au and rtl8821au. The adapter I bought online is rtl8811cu. Hopefully, the stable build will have rtl8811cu soon. Thanks again.

I know that the package we added compiles fine for 3.14. Whether it works or not is a different matter, but I don’t see why it shouldn’t work.
You removed that function because it wouldn’t compile or because it crashed on 3.14?

It did compile but there was an “Unknown symbol rtl8821c_set_mgnt_xmit_ack” modprobe error during the image creation stage and the wi-fi dongle didn’t work at all. I removed that function, the error was gone and wi-fi dongle is now working.

The driver that is used in CoreELEC nightlies gives even more modprobe “Unknown symbol” errors.

Actually, the error was: “depmod: WARNING: 8821cu.ko needs unknown symbol rtl8821c_set_mgnt_xmit_ack”

Can you please try this build and see if it works with the card?!8PpGjQxA!p516Ivq4Q0P4Yxp0ilA8M4ESLBy4HIPVRFn8KBCW2K0