Supported Usb wifi dongle


I have an USB wifi dongle with this chipset:
Realtek RTL8814AU

I would like to ask if it is possible to make it work with CoreELEC ?
The box built in wifi modul is too weak.

Thanks for your help in advance!

I don’t think this chipset is supported in the kernel, and if its the one I have I never got it working properly. The issue with it is that it seems to partially work - but the settings get lost between boots which means you have to setup the wifi each time you boot up. As such you would have to build from source the whole of CE with one of the hacked drivers that are floating about. I simply got another dongle for a tenner.


Well I can’t make any promises that I can get your wifi dongle up and working with CoreELEC.
I can however add getting some drivers compiled for you to try to my todo list for tomorrow.

Thanks for your prompt answers for both of you.

I have read a thread in this forum that the Realtek8811AU chipset is supported by CoreELEC. Thats why I tought that the Realtek8814AU could be supported too.

Since you already have the dongle, why don’t you give it a try and report back?

The output from lsusb while the device is connected would be helpful as well.

edit: I’m assuming since you said “built in wifi modul is too weak.” that you are using an s905 based box

Yes, I am using a Mecool M8S Pro W rev2.0 (2018.07.09) with an SV6051P integrated wifi chip.
It recognizes the same wifi network with different SSID’s name an it can not connect any of them…

I’ve got a test build compiling that includes drivers for the RTL8814AU. So glad I guessed right as to which platform to build for.

Which RTL8814AU device do you have?

I have this device:

Thank you very much for your kindness and hard work.

So Here is a test build of CoreELEC with RTL8814AU drivers included.

Test Build with RTL8814AU Drivers

I might still need you to get me the output from the lsusb command since the driver might not contain the device ID for your adapter. (lsusb will show the vendor and device ID I need to let the driver recognize your wifi adapter if the driver doesn’t know it already)

Just as a note the source for this test build

Thank you very much for your effort! Really appreciate that!

I will get back to you as soon as I checked this new built :wink:
Is there a new DTB file for this version or should I use the old one?

Thanks again!

Using the same DTB file, that you would use with your existing CoreELEC install, should be fine.

Finally, I tried your build yesterday.
It works perfectly fine! Thank you very much again! Your awesome!

Great. Now, at least Realtek RTL8814AU works with CE.

The driver by @cdu13a has been added to CE and will appear in tomorrow’s nightly.

I’m glad the driver worked for you.

Thank you guys for all your hard work on CE :wink:

I am glad to hear that. Thank you @anon88919003 for adding the driver.

@cdu13a did the work not me.

Hi. Sorry for the thread necromancy. Just got an ODROID-N2 today. Trying to use it with my Aukey AC1750 wifi dongle (rtl8814AU supposedly) and it is not recognized. I have an ODROID-C2 running the latest CoreElec and it is recognized there perfectly fine. Was hoping the latest nightly would have it but no dice. What should I do/collect for troubleshooting?

Edit: Created new thread here: RTL8814AU chipset support