Tanix TX9S

Hello there

Will CoreElec works on Tanix TX9S (S912 amalogic)
If yes, there is some limitations?

Product discretion here:

Hi Mate

I have just installed CE 9.2.1 on the Tanix TX9S 2Gb/8GB with Gigabit LAN. I used the this DTB (gxm_q201_2g_1gbit) from the Device Tree folder and CE booted first time using the toothpick method. Now all I want is a vfd.conf file that can turn off the blue light when power is turned off. Can anyone help?

I don’t have this box.
Just asking if works ok with CE.
If yes I buy.
Can you reply about quality playing movies?

EDIT: I found this. Try and reply


Thanks for vfd links.

I literally just installed CE and I have tested it with a few 1080p and 4K rips and they work fine via my NAS.

And VFD works? Which file you selected?

I have not got as far as VFD yet. As soon as I have done it, I will post it here. The front of the box does not have a clock; only an LED light; blue for On and red for OFF. At the moment with CE, the blue LED remains at all times.

VFD is for controlling the display some boxes come with, it won’t control the LEDs on the box.

Many thanks.

I just want to confirm with cmcarm73 in that the Tanix TX9S (Amlogic S912, 2GB/8GB with gigabit ethernet) is working fully with coreelec (9.2.1). I also used gxm_q201_2g_1gbit for the device tree. All 8 cores were detected, and both wired/wireless ethernet are functional.

I’ve tested with only a few mkv files but they all played fine. The only downsize of TX9S is the lack of bluetooth adapter, but for the price I can overlook it.

@onsmike Hi, I’m considering buying this and wondering if the remote is fully functioning?

I use a standard MCE remote with TX9S and it worked without any configuration. I also used a PS3 BD BT remote (with USB BT receiver) and it also worked without any configuration.

It is a s standard ir remote, consult with How to configure IR remote control to get it working.

Thanks, already tried 9.2 on a Tanix TX3 max and the standard IR remote is working without any special effort. I got a TX9s for my daughter…

After almost a month I’ve got the two Tanix TX9s, and installed CoreELEC 9.2.1. Running smoothly, the only command that doesn’t works with the original remote is the “mouse”. Is there a .conf file for that? Thanks :slight_smile:

I have uploaded the conf files I have found on the forum to the repo.

Or, you the can use the guide to modify your device

1 Like

Thanks, I’ll try and report back!

The front of the box has no clock; just an LED light; blue for On and red for Off. At the moment with Android 9, the blue LED remains on all the time (TX9S). Is there a way for me to change this and turn red to off and blue to on?

Same question here
I tried to disable the sysled in gxm_q201_2g_1gbit.dtb but it seems not to have any effect on the Device.
Does anybody managed to disable it successfully ?

Steps I’ve done so far:
mount -o rw,remount /flash
fdtput -t s /flash/dtb.img /sysled status disabled
sync
reboot

Edit: I done it the traditional way and opened up the Box and unsoldered the 4 pins holding, the LED.
It takes aprox 5 min for opening and unsoldering the led pin.

If you’re sure, that you won’t need the led ever again and you can’t solder, just cut the pins.
There are 4 Pins for 4 colors, the blue one is the second one from the left side (if you watch at the pins from the hdmi, power ports side).

Btw for every new Tanix TX9s owner.
“Installtointernal” is working perfectly, but bare in mind, that if you do this, you won’t get any Support from the stuff.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice