TOX3 - Missing partition super on eMMC

TOX3 - Amlogic S905X4

Has anyone managed to resolve this issue of "Missing partition super on eMMC”?
The last version that works without this error in TOX3 is “CoreELEC-Amlogic-ne.arm-20.2-Nexus-Generic.img.gz”.

The current version “CoreELEC-Amlogic-ne.aarch64-20.4-Nexus-Generic.img.gz” is starting to show "Missing partition super on eMMC”!

I did a test on “CoreELEC-Amlogic-ng.arm-20.4-Nexus-Generic.img.gz” and it worked without the error!

I tested “CoreELEC-Amlogic-ng.arm-21.0-Omega_beta3-Generic.img.gz” it also worked without the error!

I tested “CoreELEC-Amlogic-no.aarch64-21.0-Omega_nightly_20240301-Generic.img” and also got the error "Missing partition super on eMMC”

Does it have to do with this “aarch64”?

Use forum search…

Yes, I used the search, but I didn’t find the solution, I’m using it on the micro SD too! Is it because TOX3 is 32bits?

Try the. no Omega version - it’s working fine for me, ethernet and wifi. I use slimbox ATV as boot loader and run from SD card CE Omega no.
You could update your Android firmware also. And try again with CE.

I retest with CoreELEC-Amlogic-ng.arm-21.0-Omega_beta3-Generic.img.gz and wifi and ethernet works great now.

I just tested CoreELEC-Amlogic-no.aarch64-21.0-Omega_nightly_20240301-Generic.img and it continues with the error “Missing partition super on eMMC”, all versions that contain this aarch64 are giving this error. Would it be possible if I Would clicking reset tv box on android resolve this error?

Dunno if resetting the Android could be helpful but go and try it. I would use Amlogic burning tool to install or update the firmware.

I did a factory reset on Android and it didn’t help, I checked that it’s on the latest firmware version from November. V.3.4.231103.

I’m not willing to re-download and install the firmware via cable, as I think it’s a bit advanced and I’m afraid of harming a product that is working normally on Android.

I’ll leave it as is and use the CoreELEC-Amlogic-ne.arm-20.2-Nexus-Generic.img.gz without “aarch64” version or the Amlogic-NG versions which are normal too.

Can anyone explain what this “aarch64” is? Only the versions that have it give the error!

Stay safe with. ng on external - if that is working for you!

It’s mostly about 32 VS 64 bit architecture on Arm procs.

1 Like

I have the same issue, 20.2 NE worked w/o issues, now I have the super eMMC, android is running on my TOX3, latest version… this might be it for now with the TOX3 :frowning:

1 Like

Does the slimbox ATV have a super partition, as I cannot get .no Omega to work with playback bc of the missing super emmc partition…

So I guess if it works with you than the slimbox ATV should have super patition.

That’s special. I have “no nightly” running on my TOX3 without this super partition message. Original Android on emmc and Corelec on SD. With the first “.ne version 20.0” I also had this message permanently, but back then the user space wasn’t Aarch64…then I switched back to ng. And now with .no I’ve never seen this message again.

By chance is your version of TOX3 from the “Woopker” store? Could this be it? Will if we install Slimbox ATV we will have the “super partition”?

After this restructuring, the Kernel Version went from 5.4.125 to 5.4.210, that is, until “CoreELEC-Amlogic-ne.arm-20.2-Nexus” was 5.4.125, after that it became “CoreELEC-Amlogic-ne .aarch64-20.3-Nexus” forwards the 5.4.210 kernel with the “aarch64” framework.

When accessing the original Android firmware (V.3.4.231103) and opening AIDA64 I can see that the version is Kernel Version: 5.4.125, I don’t know if this is related. But maybe to be able to use the new CoreElec with “aarch64” we need an official firmware update with a new kernel…?

Dont know, as I bought it from a guy… and also not sure if slimobox ATV will have super partition.

What I do know is that on 4pda

There is one guy that has created 2 forks of 2 stock firmwares with “enlarged partitions” which I guess it`s the same (super).

I download the TOX3_3.3.221221.img flashed it with the amlogic usb burning tool and was able to run w/o issues no (new order) 21 RC1 Omega but wasnt so good (nighty) so I returned to latest stable NE 20.5 and it`s perfect!!!

1 Like

Thanks for the feedback, at least we know it works thanks to you! I have never used flash on any TV box before, perhaps now is the time not to be left behind, I will provide a cable, thank you.

1 Like

Update and problem resolution, I installed SlimboxTV using the Amlogic USB Burning Tool! After many attempts, using a 1m cable, I only managed it because I used an Essager USB Adapter, directly in Windows it didn’t recognize the TOX3 at all!

TOX3 slimBOXtv 34.1 TOX3 / TOX3 lite TV box - Обсуждение - 4PDA

Finally I managed to use all versions, including “aarch64”, the best one I tested was “CoreELEC-Amlogic-ne.aarch64-21.0-Omega_rc1” which plays VC1 smoothly and suspend mode with AVR!
the “CoreELEC-Amlogic-no.aarch64-21.0-Omega_nightly” version is nice, but VC1 and suspend mode with AVR doesn’t seem to be playing normally.

Apparently the problem must have arisen after some firmware update on Android, launched by the team itself that corrupted the super partition perhaps? But the android worked normally.

This is my first time using Amlogic USB Burning Tool, it was difficult to recognize tox3, but after that it was quick!

Now suspend mode works great with q990c AVR in “CoreELEC-Amlogic-ne.aarch64-21.0-Omega_rc1”
Before, when returning from sleep or suspension mode, the coreelec would freeze, and I had to forcefully restart it, so I wasn’t using sleep mode, I just left the box on. Now everything is working so perfectly wow. If I had known that it would solve so many problems, putting new firmware on the box, I would have done it long before.

1 Like

Fantastic news! Kudos to this guy that forked the stock android firmware to support the super partition.

I believe that I read NO New Order wont officially support GXL (i.e. S905X4/Tox3) so NE is as much as we will get…

I still really love the Tox3, what an incredible rock solid device with proper support from the great coreelec team!

That’s not right, GXL is S905X. S905x4 is and will be supported


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.