Trouble with ssh to N2

#1

Got an N2 in the mail today, nice bit of hardware. Wrote the eMMC with a USB writer and booted no problem, but the N2 won’t let me ssh into it. I can’t do anything since I’m not able to get the remote working at this point. I can see the shares in Windows and write to them but I get the following when I try to ssh into the board;

C:>ssh root@192.168.0.157
ssh: connect to host 192.168.0.157 port 22: Connection refused

Thanks for any help.

#2

SSH is disabled by default. You can connect a USB keyboard or mouse to the N2 and enable SSH in CE settings.

#3

Thanks, all I have are laptop computers, can I do it from the shares?

#4

Unfortunately not as the required files that need to be modified are not exposed via Samba.

You can plug a USB keyboard or mouse into your N2 and enable SSH via CE-settings that way.

#5

Okay, I’ll have to go buy a USB mouse then. Why the change? I could ssh into my Le Potato on the first boot. Thanks.

#6

You might want to try Yatse (or other remote app), if you use android phone. HTTP remote control is enabled by default, iirc

#7

For security and to bring us in line with other distributions, SSH is disabled by default in most distros.

9.0.2 Discussion
#8

You can copy everything from the storage partition of lepotato to the storage partition of n2. It is an ext4 formatted partition so you will need something to read Linux partition in windows.

#9

I got a hold of a mouse and plugged it in, no problem, enabled ssh, on my merry way.

I forgot about the http interface, should have tried that, would have saved me some trouble. Actually I think I tried it, but I forgot about the port 8080 thing, more convenient if the default port was standard. Probably a security thing again.

Would be nice if Windows could read Linux partitions out of the box. But that would never happen. I’m actually surprised there is a selectable feature of Windows that provides some Linux support. Mostly MS has done everything they can to disregard Linux.

In general I don’t like this modern idea of security at the cost of convenience. It’s not the developer’s job to police the users. I mean blatant things should have a default on the side of security, but for something like setup it’s just over the top.