Trying to recover MXIII G II S912 TV Box from what looks like corrupted/dead internal memory

I don’t see such a thing , this is how my tool looks and works.

Start CE and copy meson1.dtb to / storage
then run in the ssh terminal:

dd if=/storage/meson1.dtb of=/dev/dtb

meson1.dtb (86 KB)

1 Like

Oh true, my bad - thinking of different device. Sorry
Then I guess what you need is recovery.img and / or boot.img for your device to flash with adb. There must be a way to extract those from the .img you already have, I just don’t know it off-hand.

1 Like

scp ~/Downloads/meson1.dtb root@
And got:
meson1.dtb 100% 86KB 4.2MB/s 00:00
ssh root@
dd if=/storage/meson1.dtb of=/dev/dtb
And got:
172+0 records in
172+0 records out
88064 bytes (86.0KB) copied, 0.001018 seconds, 82.5MB/s

What do I do next?Should I try again with the Burn Card Maker and your .ini?:slight_smile:

Yes, repeat the OTA update.

1 Like

I did that and I still get this :

I unpacked the contents of the both images (update_MXIII-GII_rv109.img, update_MXIII-GII_rv112.img) and found that the files _aml_dtb.PARTITION and _aml_dtb.VERIFY are missing. Thus these images are not suitable for the OTA update. You need a full-install image.

1 Like

I just noticed that in this case dtb file must be written to the partition “reserved”,sorry, my mistake.

dd if=/storage/meson1.dtb of=/dev/reserved
1 Like

It seems to me that the fact that you are getting a low quality picture for the Android robot points to the fact that the images you are using are not right for your box and you probably have the wrong dtb.img. I have personally never seen such a boot image in greyscale before.

Just a thought.


1 Like

Thanks for sticking around are trying to figure out what it is :slight_smile:

So I did :
dd if=/storage/meson1.dtb of=/dev/reserved
And I got :
172+0 records in
172+0 records out
88064 bytes (86.0KB) copied, 0.518800 seconds, 165.8KB/s

I still get the android with the X thing unfortunately.

About the image, I will try to look for some more , or maybe I could pull those files from a similar firmware or something, but I saw a lot of people on freaktab saying that this firmware worked for them:

Vendor links the firmwares#28:

These are the links they posted:!j1wTURCQ!H6pLEGCtk-s0bMZ6jDU7JFH7EJgFyMprwkkhP9heTrk!D1IhnRBS!bwov8ZBpMjjRv2qTGq_3Ofs3kxGo2GTyHZihI8vxsng

I also saw people on freaktab saying that this custom ROM below works for their MXIII GII S912:

Thread where someone says it works for the box#248:


Custom ROM Thread:

Custom ROM Download:

I will download and try to install these via the Burn Card Maker method and then come back.

Edit1: I tried the custom and and saw a blue background a droid and a link to and then it went back to the droid with a X sign.
Edit2: I tried formatting the card as FAT32 then copying the contents of to the card but it won’t boot, maybe I need to dd something there?;however TWRP worked with just formatting as FAT32 and copying and renaming the image to recovery.img without dding anything.
Edit3: I tried formatting the card as FAT32 then copying the SD firmware again and this time it booted to a black screen.

Post#225: Here you can see a guy trying to flash a custom ROM getting this image.

Then here:

Post#226:You can see the same guy saying that it worked with the same image but with a different card.
Also Post#236 getting the same image with the stock firmware.

As said previously you will require the FULL original image to restore properly and not an upgrade image.

If I ssh intro CoreELEC and do:
cd /dev

SYSTEM              loop6               tty38
amaudio             loop7               tty39
amaudio_ctl         mali0               tty4
amaudio_utils       mem                 tty40
amhdmitx0           mmcblk0             tty41
amremote            mmcblk0p1           tty42
amstream_abuf       mmcblk0p2           tty43
amstream_hevc       mqueue              tty44
amstream_mpps       net                 tty45
amstream_mpts       network_latency     tty46
amstream_rm         network_throughput  tty47
amstream_sub        null                tty48
amstream_sub_read   pmsg0               tty49
amstream_userdata   ppmgr               tty5
amstream_vbuf       ppp                 tty50
amsubtitle          ptmx                tty51
amvecm              pts                 tty52
amvideo             random              tty53
amvideo_poll        reserved            tty54
amvideocap0         rfkill              tty55
aocec               rtc                 tty56
ashmem              rtc0                tty57
audiodsp0           shm                 tty58
autofs              snd                 tty59
block               stderr              tty6
bootloader          stdin               tty60
btrfs-control       stdout              tty61
bus                 sw_sync             tty62
char                tty                 tty63
console             tty0                tty7
cpu_dma_latency     tty1                tty8
di0                 tty10               tty9
disk                tty11               ttyS0
display             tty12               ttyS1
dtb                 tty13               ttyprintk
efuse               tty14               tv
esm_rx              tty15               ubi_ctrl
fb0                 tty16               uhid
fb1                 tty17               uinput
fd                  tty18               uio0
full                tty19               unifykeys
fuse                tty2                urandom
ge2d                tty20               vcs
gpio_keyboard       tty21               vcs1
hidraw0             tty22               vcs2
hidraw1             tty23               vcs3
hwrng               tty24               vcs4
i2c-0               tty25               vcs5
initctl             tty26               vcs6
input               tty27               vcsa
ion                 tty28               vcsa1
kmem                tty29               vcsa2
kmsg                tty3                vcsa3
log                 tty30               vcsa4
loop-control        tty31               vcsa5
loop0               tty32               vcsa6
loop1               tty33               video10
loop2               tty34               wifi_power
loop3               tty35               zero
loop4               tty36
loop5               tty37

So I think all the files I dd are going to the CoreELEC SD card not into the internal memory.

Is there any way to make the box use the SD card as internal memory or somehow install android on the SD card?

  • No. They are eMMC partitions.
  • Yes, but it is very time-consuming. Please keep in mind, we are not in the Android forum. :slight_smile:
1 Like

If I boot from another card with CoreELEC on it and ssh cd /dev then ls the bootloader,dtb,reserved folders are no longer there.

what I have noticed so far - partition “boot” is missing. Please type the following command and show the result

ls /dev | grep boot

Furthermore, a complete boot log would be appropriate. Please read how to establish a uart connection between the box and the PC.

I have exactly the same problem as Bojan but on different device.
Have Sunvell T95V Pro (S912, 2gb/16gb)
It’s bricked, just power led, no signal, no recovery, nothing.
USB burning tool don’t recognize the box, unless I short two pins on nand. Then I tried to flash all the roms I can find, but always the error at 7%-formatting…
Tried with the SD card method but also without success. Box won’t boot from SD card, unless I short two pins on nand. Have tried with reset button first, but nothing happens.
When shorting pins, get android robot and “upgrading” but hangs forever at the beginning, same like Bojan.
Then I tried with CoreElec, burn card with s912 image, but all the same, won’t boot unless shorting pins. Then it boots perfectly and everything works very well.
I tried also “installtointernal”, it start’s but hangs on “system-formatting”. Think that EMMC is busted, not corrupted or blank but dead, because it refuses writing on any way.
So, is there any way to force the box to boot from SD card when the emmc is broken?
Bojan’s case is little bit different than mine. I read on this theme that solution was to write “aml_sdc_burn.UBOOT” from working stock image to SD card with coreelec, but problem is that my box won’t bot with any stock upgradable firmware from SD card without shorting pins.
When coreelec is loaded it works flawlessly, but it’s very annoying to shorting pins every time I gonna watch something…
Any help?

Just to say that I managed to solve the problem.
First burn CoreElec to SD card, then use Amlogic Boot card maker with from stock firmware, just UNTICK option to format.
When done, put SD card to box and boot straight away to CoreElec, without shorting pins.
Now everything is working excellent.


many thanks i had a similar problem and you solution worked fine for me :+1:

Hello Nebojsa!
I know it’s been a long time since your post, but I’m trying to revive a T95vPro like yours and I run into exactly the same problem with the addition that I don’t have the original firmware nor can I find it anywhere. All the links I find to this firmware are down.
If you still have it and it’s possible for you to share it in some way, I would appreciate so much.
Thank you in advance