TX3 Mini not booting (new board?): B00-MX3Mini-REV1.6

Hi Guys!

I am trying to boot without success in this TX3 Mini (S905W) board.


Already tried a lot of different systems and versions (emuelec, batocera and coreELEC).

They all get stuck in TX3 Mini Logo after the reboot.

The board don’t have reset switch (as you can see in the pictures).

Not even in the P2 plug.

Tried the following reset methods:

App Reboot to LibreELEC

App Terminal command (reboot update)

Update and backup from system menu

The chip has S905W written on it.

And, by the info on Kodi, it seems to be the right chip.



hi! thanks for the reply!
tried with this image:

and all 4 variations of p281 dtb files.

processor seems to by right

also, tried in flash card and a usb pendrive.
same result. always, stuck in tx3 mini logo

renamed to

There are several potential reasons:

  • locked Android Bootloader
  • Incompatible (outdated) Android Bootloader
  • Fake HW (CPU-Z can be easily fooled by Android), see: link
  • In case of issues getting CE booted at power-up, you may try to short-circuit the two pads of the (unplaced) pushbutton:

thanks for the reply!

just tried the p821_1g (with the app to rebboot to librelec)
now, it keeps rebooting. not freezing anymore.
but, still not passing the TX3 Mini logo.

the fact that it keeps reooint in loop is a sign that the bootloader is trying to read from the card?

just tried short circuit to boot. same “new” result. loop on boot with 1g stb

Only a UART log will show what’s wrong.

^^ what Portisch said

Additionally, you could check on Android terminal the result of cat /proc/device-tree/amlogic-dt-id

how can i get it?


So it confirms GXL S905W with 1GB Ram.
But seems the real reference design platform of your board is p271, which is not supported by CE.

Try all dtbs, if no hit please infest €30 for a device with actual SoC.

EDIT: even more cheap:

(it’s not supported by Team CoreELEC but it looks like working)

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.