Ugoos AM6 Plus and eMMC

My new AM6 Plus boots into CE from SD card and works fine. :white_check_mark:
The next step would be to get CE boot from internal memory (eMMC). As we know, Ugoos offers a dual-boot firmware.
In some other thread it was recommended to stick with regular FW and use ceemmc to put CE on the device. Did I get that right? Anyway, the installation via ceemmc seems to have worked OK, according to the message output.
However, the device continues to boot into Android. None of the two toothpick holes seemed to get me into CE. Since others reported success, I am wondering what I might have missed.

Thank you!

Try long pressing the power button on your ugoos remote whilst on the android homescreen, top right hand side of screen a drop down menu will open withe the option to boot into CE.

But that’s only with the official dual-boot firmware, no? IIRC, someone recommended single-boot FW and ceemmc, because that way both systems could be updated independently or something.

insert uSD/USB CE again and boot, run ceemmc again. some user report it was needed to run the tool twice

Try turning it off and then holding toothpick for a few seconds in the ‘reset’ hole, untill it shows CE or ‘Upgrading’ on screen. If that doesn’t work boot from SD and repeat ceemmc install one more time and then again turn off and start with toothpick in ‘reset’ hole, but don’t release toothpick until it starts booting. You will need this toothpick method every time after using Android if you have not installed official dual boot, because single android official install doesn’t have menu option to restart to coreelec.

Just to make sure we are on the same page: There are two buttons, “Recovery” and “Maskrom” (no “Reset”). Starting with the former pressed will show the “Upgrading” message, load the recovery image and take me into the recovery mode menu. None of the options in that menu will get me closer to my goal. The button labeled “Maskrom“ has no obvious function.

Yes, sorry about that, I’m at work, not near device. I meant the ‘recovery button’. If that one doesn’t boot into coreelec I suggest you repeat the ceemcc -x install. Something didn’t complete the first time.
Even though counterintuitive you may want to leave SD card inside the device after finishing ceemc install and when restart happens. It will ensure to boot from recovery (in this case either SD card or emmc install), device remembers last boot device. Then shut down again and remove Sd card and start again.

Function of ‘Maskrom’ is flashing the firmware via OTG USB cable, sometimes for some versions of firmware you need to have it pressed for the whole duration of firmware flashing via pc with amlogic burning tool. Even for official firmware sometimes.

Thanks for trying to help. Sadly, none of this helped. Another odd thing I noticed (compared to my previous box) is that CE doesn’t show the eMMC in “Storage” (which kind of rules out the SD+eMMC option).
The tool ceemmc, OTOH, does seem to see it:

CoreELEC:~ # ceemmc -x

Starting CoreELEC eMMC installation tool...

System is not supported: g12b_s922x_ugoos_am6!

There is NO official support by Team CoreELEC
if you continue to run this tool!
Continue? [y]: y

eMMC size: 0x000747c00000 [32GB]

No CoreELEC installation found on eMMC

Install in dual boot mode, CoreELEC and Android on eMMC
  Use CoreELEC data from
    [1] current used SD or USB device
    [2] existing backup on current used SD or USB device

Install in single boot mode, only CoreELEC on eMMC
  Use CoreELEC data from
    [3] current used SD or USB device
    [4] existing backup on current used SD or USB device

Please choose one option? [1/2/3/4]: 1

Free space of 'partition CE_FLASH': 512MB
Free space of 'partition CE_STORAGE': 17599MB

Used space of '/flash': 222MB
Used space of '/storage': 7566MB

There is enough free space on eMMC for installation!

Install CoreELEC on eMMC.
Continue? [y]: y
e2fsck 1.45.3 (14-Jul-2019)

resize2fs 1.45.3 (14-Jul-2019)
The filesystem is already 6653440 (4k) blocks long.  Nothing to do!

Starting to format the new 'CE_FLASH' partition...
mkfs.fat 4.1 (2017-01-24)
Stopping Kodi before start of copy process!

Starting copying of data to the eMMC!
Please do NOT interrupt this progress till it's finished!

Copy all data from '/flash' to '/media/CE_FLASH'
        222.90M 100%   23.97MB/s    0:00:08 (xfr#68, to-chk=0/75) 

Syncthing, please wait...
Copy all data from '/storage' to '/media/CE_STORAGE/coreelec_storage'
          7.57G  99%   17.59MB/s    0:06:50 (xfr#20265, to-chk=0/24146)   

Syncthing, please wait...
Start Kodi again to have a user interface!


You can now power off the device, remove the used boot media (SD or USB) and
power on again to boot the device from eMMC!

What version of official FW have you got on the device? Maybe it’s older version. I think for later versions of CE, it’s recommended, maybe even required to have latest official manufacturer firmware.
You can check here:

I have the same device, and have also flashed latest official dual boot (Android + CoreElec) fw
CoreElec in that fw isnt latest but 9.2.2 I think. I’ve immediatelly updated it to stable 9.2.5 via automatic update and it worked perfectly for a few weeks.
Since then I’ve updated it to CE19 Matrix beta, and it also works perfectly. I would also recommend that you determine which revision of hardware you have. And choose DTB file accordingly.
Also you can keep using SD for Coreelec, it is the recommended way for usage. Unles your SD card is too slow, or much slower than emmc. It’s easier to recover from that if something goes wrong. I did install to emmc but I’m proficient enough to recover it if something breaks during flash.
Also official dualboot firmware has remote controller already setu up and configured. The config files are somewhat hidden. If installing CE on this device by yourself from CE download, it’s needed to download remote controller config from unofficial repository and manually copy it to appropriate folder.

Thanks again. The installed FW is also So you are using the dual-boot? Maybe I’ll just try that and be done with it. My primary use for Android would only be to update lower-level device FW.
My SD card is quite slow, but I’d also hate to waste 32GB of eMMC for no reason.
I suppose the S922X-J of the AM6 Plus is always revB, so the regular DTB should be fine:

model name	: Amlogic S922X rev b
Hardware	: UGOOS AM6
Revision	: 0400

I’ve used CoreElec on multiple devices with single install to emmc and never needed Android since. But lately since I’m waiting for my preordered PS5 almost 4 months now I had an itch for bigscreen gaming and wanted to try SteamLink android app and play some games on tv. So that is the only reason I installed android, meaning dualboot. But I suspect that I will revert to single install to emmc without android whatsoever as soon as my ps5 arrives. Please let me know if you manage to install CE to emmc.
I had to hold maskrom button pressed the whole duration of installing dualboot fw.
There is somewhere on this forum appropriate command to execute from shell to determine serial and revision.

You could also try to execute command from Android:

reboot update

And check if it starts CE from internal or not.

1 Like

So I tried a CE-only installation using ceemmc and bricked the device. Couldn’t even get into recovery anymore. Unbricking is simple enough and I took the opportunity to install dual-boot. Great, CE starts from eMMC now. However, a /storage size of 3GB (of 32GB) is ridiculously small. So my goal eventually is to do what I tried first, i.e. single-boot+CE.

Not here. (using the USB flash-tool)

Ah, thanks. Using ADB I suppose?

Sorry to hear that following my advice bricked the device. Glad to hear that you managed to recover it. Curious about maskrom button, I’ve used Amlogic usb burning tool, that came with fw, via PC. Interesting. As I recall, a few months ago during earlier fw revision I didn’t have to press that button. But this time it would start and fail with some error in first 20 seconds if I didn’t hold the button pressed.

If you bricked device with CE single boot, than it possible something changed in 0.3.9.x firmware.
And my solution don’t help you.
I could test next week only if they have some broken changes in latest firmware.

No worries. I’ll keep experimenting and report.

Maybe this part from official fw page:

is the cause?


Yep, if they have encrypted bootloader then it could be a reason

Does that mean, dual-boot FW or SD-card will be the only two options? In that case we should convince them to dedicate more memory to CE.