UGOOS AM6 Plus fails to initialize CEC

I haven’t been able to find it in archive, could you share it ?

Sure. Sorry for late answer, I must have missed notification, been busy a lot. I only have upgrade file, don’t have new install image.
I have it installed into internal memory. The way I do it with Ugoos AM6 on encrypted firmware is first installing official Ugoos dual boot firmware, reboot into CE. Ugoos put CE 9.2.2 version. Then I update it from this file by simply putting it into .update folder. It works for updating from CE 9.2.2, and also from CE9.2.7 if it automatically updates to latest CE 9. Of course, the same as CE devs, I also don’t recommend installing to internal memory unless you’re absolutely certain of what you’re doing and aware of the risks associated. Injecting bl301 will not work on Ugoos encrypted versions of firmware (from 0.3.7 upwards if I remember correctly).
For recommended way of installing to micro SD card, I would first install latest single boot Ugoos Android firmware (because if you install dual boot it will default to booting coreelec from internal memory every time and would only boot from SD card if you press recovery button), and put latest CE 9.2.7 new install coreelec img to SD card. Then i would boot to SD card by using recovery button. and then would upgrade to provided CE19 beta nightly. Make sure you reject and turn off updates otherwise it would autoupdate to latest CE19.2 stable/nightly.
Please let me know if you need any assistance.
Also if you do it via SD card, don’t forget to download remote config files for Ugoos AM6 Plus remote from repository. Put it into root of prepared SD card or later place it into .config folder of CE and reboot.
I may as well attach it here too:
If you use dualboot from Ugoos the file is already present and you don’t need to do anything in order to use ugoos remote controller.

Thank you for the files and explanation. A few weeks ago, when they released v0.4.1, I tried flashing the official dual boot firmware and almost lost control of the device for good. So I’ll test this soon on a SD card.

I confirm that CEC works with this version (Amplifier volume control and TV + Amplifier power off with DENON AVR-X2400H and PANASONIC TX-65EZ950E).

Is there a chance that CE devs would look into this now that we have a (second) proof that it works with CoreELEC-Amlogic-ng.arm-19.0-Matrix_nightly_20210113 and not with the most recent version ?

1 Like

No idea. As you can see here CE did not change anything on 13.01 or 14.01:

You only can enable Kodi debug logging and libCEC component to make a CEC log.
Also post your libCEC config.

Bad CEC combination is:
TV + AVR + CE box, avoid it and connect the CE box directly to TV
Panasonic TV: the brand is known to have a limited (faulty) CEC implementation

[quote=“Portisch, post:25, topic:14821”]

This combination always worked well TV + AVR + CE box. When I had problems with cec not to long ago it was my N2 connected directly to my TV. The problem was the auto detect. When I entered the address manually as you suggested it worked. Auto detect is back working and running 2 minix u22 without issue.

kodi.log (104.6 KB)

I am using the same cables, TV amplifier. CEC works perfectly (meaning every time and not randomly) on the TANIX TX92 and it works now with ugoos AM6 and 19.0-Matrix_nightly_20210113

CEC may be faulty in the TV but it works with the old version.

What I mean by CEC works is that using the CE box remote I can adjust the volume of the amplifier and power off / on all 3 devices connected through HDMI.

The connections have always been the same CE box + amplifier + TV. I tried the CE box directly connected to the TV but that produced zero change. Only the downgrade of CE changed from non working CEC to working CEC.

Here is the kodi log.

1 Like

Sorry, i don’t understand what the problem is. Maybe it also help, especially when using AVR, to set the correct physical address in libCEC config.

The problem is that we (depending on what amplifier and TV is connected) cannot make CEC work with the newest CE versions. Maat236 reported that it works with 19.0-Matrix_nightly_20210113 and I confirmed that too yesterday. I always had 0 as physical address but I changed it as you suggested. It does not work either but here is the log (from 19.2-Matrix_nightly_20210609).
kodi.log (384.1 KB)

I downgraded again to 19.0-Matrix_nightly_20210113, even leaving physical address to 6300 and CEC works immediately after reboot.
kodi.log (228.8 KB)

Try 3600, not 6300

I tried (before downgrade) but no cigar.

Now, using 19.0-Matrix_nightly_20210113, it works with physical address 0. I even tried 1488 but had some problems.

There is nothing to try, first number is HDMI port TV, second HDMI port AVR followed by two 0.
And the TV does have 6 HDMI ports?

And the log shows clear there is something faulty on you CEC hardware, maybe the AVR connection, HDMI cable or CEC at the TV is disabled at all:

2021-06-13 09:15:24.274 T:5022    DEBUG <general>: CecLogMessage - << Broadcast (F) -> TV (0): POLL
2021-06-13 09:15:24.275 T:5022    DEBUG <general>: CecLogMessage - << f0
2021-06-13 09:15:24.285 T:5022  WARNING <general>: CecLogMessage - Write: write failed

There is no response from the CEC bus. We had a user in past with similar issue but I don’t know how he resolved it. But the issue is for sure not CE.
Try clean, fresh install from last 19.2-Matrix_rc2, other HDMI cable, other HDMI ports with and without AVR and so on.

No, it’s connected to port 6 of the amplifier (and to another port without number called HDMI OUT, MONITOR1 ARC). From your comment, I guess that I should have used a smaller number (the port behind the TV), both HDMI1 and HDMI2 ARC are connected.

So, could it be 1600 ?

Do you have CE->TV->AVR or CE->AVR->TV configuration?

The connections have always been the same CE box + amplifier + TV.

I have CE box connected directly to Hdmi port of tv. Behaves exactly like user DeepAnger reported. Cec works reliably only with mentioned Ce19 beta nightly 20211013. I’ve tried different Hdmi ports on tv, different cables but it is always the same. The cec works at first with any ce19 stable or nightly, until i change input source on tv (to playstation for example) and change it back, or if I turn off tv or put it to sleep and than back on. Cec stops working then (untill rebooted), except on Ce19 beta nightly 20210113, with this version cec keeps working no matter what I do. Something was clearly changed in between this beta and the first stable version. There was mention of cecA vs cecB at some point in time, wasn’t there? Maybe it could have something to do with it? I also have Panasonic tv, so I understand it is probably a fringe case and most probably the fault lies with Panasonic. Nevertheless, something regarding how CE handles CEC must have changed, driver, library or something else entirely. Otherwise it would not work with that beta nightly version consistently.
Thank you all for all your effort and advices. Is there any way I could try and change CecA vs CecB implementation manually? CE 19 is great and exceptional multimedia center, I’m grateful for all the work and effort you put into it. It is awesome for my daily use for watching and recording dvb-t, and also watching movies and tv shows from NAS.

1 Like

As you are only a few people having issues please try first a clean fresh install with last 19.2-Matrix_rc2. it works for thousands other people, so I don’t think there is a bug. It’s some user side issue.

There were some changes (improvements) in past and maybe when only update CoreELEC the config is broken.

So perform a clean fresh install and make a libCEC log again.

1 Like

And when I read this what is the conclusion: AM6 CEC is faulty.

I am again +1 to remove Ugoos (AM6) support at all as they encrypt the bootloader and implemented some unsupported dual boot (not tested or approved by Team CoreELEC). We have no idea what can cause this issue as it can also some fault in Ugoos bootloader.