Unreliable IR receive on video play

Remote become unreliable in the moment any video starts playing - longpresses no longer work, and wrong key presses trigger sometimes, while many normal are lost.
The effect vanishes just as video stops.
Android has no such behavior.

By description it’s very similar to analogue RPi problem: https://github.com/raspberrypi/linux/issues/906, but the difference we have hw IR receiver which should not suffer the problem.

amremote IR driver with NEC remote.conf (work_mode = 0), s905x, CE 9.2 Amlogic

  • any thoughts I can do with the problem?
  • what is the status of android kernel on CE? I saw it has newer IR driver, maybe that is the reason
  • anyone else has this problem?

@adamg @Portisch

1 Like

Looks like I’m not alone:

mine revived . I have no clue how, but now it works…

Then it probably completely different problem…

PS:
@Pinzarufilip can it be you are just trying different streams?

It’s kind of magic here. Now it works for me too.
I didn’t change anything, but tried since ~1 week and now it just works!
I can’t reproduce my problem now, and can’t really imagine what was happened.
Any ideas?
@adamg @Portisch

Right now, by playing some videos I could replicate the issue.

  1. Using “----------” addon to stream the movie 4kHdr atmos - remote working OK

  2. Using a NAS with NFS share -same movie with same bitrate - remote is unresponsive

It can be possible to be a poblem on coreelec with NFS share

Thank you !

It’s not, because I have never had NFS share.
Could you try to reproduce it on some on-line stream?
But I actually had the problem in PVR-Demo addon which works OK now…

It’s fine you can reproduce it anyhow, though.
By the way - are you connected via Wifi?

Yes , on wifi. Because I cannot fix the Lan on the X96 max 4/32 :frowning:.

Do you remember what stream cause the problem first time?

I’m having the glitches again :man_facepalming:

Mee too. Same issue, but only on some videos…

Could you please try it on PVR Demo addon’s channels?