Unsupported dtb

I am receiving the unsupported dtb error on startup with the countdown. I have a MAG410 box on which I installed to Internal using the generic S905 image.

Can anyone explain if I can update the dtb on an installed to mmc and if so how to proceed?

Thanks

Which DTB did you use when installing?

I can’t remember but when I run “cat /proc/device-tree/amlogic-dt-id” I’m getting gxl_p212_2g

Can you do cat /proc/device-tree/le-dt-id

cat: can't open '/proc/device-tree/le-dt-id': No such file or directory

Then this is your problem, your not using a CoreELEC dtb.

You must have used a dtb from another source during your initial installation.

The following commands should resolve your issue.

dd if=/dev/zero of=/dev/dtb bs=256k count=1
dd if=/usr/share/bootloader/device_trees/gxl_p212_2g.dtb of=/dev/dtb bs=256k

Thanks for your help. I’ll test this out and let you know if it resolved the problem.

For anybody else reading this thread, do not use the commands above without asking for help first as the dtb you need to use may vary from the one above.

I assume if you reboot the machine before writing a new dtb.img after zeroing /dev/dtb that this will have catastrophic results

I wouldn’t say catastrophic as every issue is fixable.

Fair enough :grin:

Hi.

After I updated to 9.0.2, I have the same problem as original poster except I am using Tanix TX3 Mini 2G. According to DTB list, I should use “gxl_p281_2g”. So, can I use the same commands proposed with, of course, the different dtb?

dd if=/dev/zero of=/dev/dtb bs=256k count=1
dd if=/usr/share/bootloader/device_trees/gxl_p281_2g.dtb of=/dev/dtb bs=256k

Thank you.

Yes, that should solve your problem.

But if it installed on SD card(and not in internal), than you only need to replace dtb.img file to correct one on sd card.

Commands successful. Althouth the box rebooted 3 times at the CE logo before Kodi started and now is booting without 60s delay :sweat_smile::+1:

CoreELEC:~ # cat /proc/device-tree/le-dt-id
gxl_p281_2g
CoreELEC:~ #

Thank you, guys

Hey Adam,

I’m using Coreelec installed to internal on a T95m box.
after updating from 9.02 to 9.03, i’m getting the same “unsupported dtb” delay upon bootup.

cat /proc/device-tree/le-dt-id responds with gxbb_p200_2G_100M_t95m which is the tree that worked before.

Which dtb should i use now and how to put it in - just copy over into update folder?

Thank you,
azido

There is no dtb with this name included in the CoreELEC images, so it is most probably one from Android or another source.
According to our device tree database the right one for a “Sunvell T95M” would be gxl_p212_2g.

Please follow the instructions on our website to copy the right dtb to the root of your sd card:
https://coreelec.org/#install

gxl_p212_2g is for S905X. There were T95M boxes with a S905.

@azido Try gxbb_p200_2G_100M.dtb

1 Like

I’m not sure how to exchange dtb on an internally installed coreelec.

I thought it would be as easy as throwing it into the update folder, but it isn’t.

Anyone willing to enlighten me?

cheers,
azido

Before you do it on your eMMC, create a SD card with this DTB and make sure it works. This step is to avoid bricking your box if the DTB doesn’t work.

To update the DTB manually on your eMMC, boot from eMMC and run the following commands in SSH:

mount -o remount,rw /flash
cp /usr/share/bootloader/device_trees/gxbb_p200_2G_100M.dtb /flash/dtb.img
reboot
2 Likes