Unsupported dtb

Thank you,

went fine with testing dtb on sdcard, all up and running. But remount command failed with “no such file or directory” although /flash dir exists.

Aaah, never mind. The -o was missing in the commandline.

Sorry about that, I edited the command.

1 Like

just felt a bit mad why it’s not working :wink:

Still no change on boot behaviour, dtb.img is placed correctly in /flash, but it looks like the system simply does not touch it at all.

Is there something that’s missing?


A kernel maybe?

CoreELEC:~ # ls -l /flash/
total 171888
-rwxr-xr-x    1 root     root     161972224 Jan  1  1980 SYSTEM
-rwxr-xr-x    1 root     root            48 Apr 10 13:54 SYSTEM.md5
-rwxr-xr-x    1 root     root         30176 Jul  3 04:05 boot-logo-1080.bmp.gz
-rwxr-xr-x    1 root     root          1962 Jan  1  1980 boot.ini
-rwxr-xr-x    1 root     root          5257 Jun  3 13:01 config.ini
drwxr-xr-x    2 root     root          8192 Jan  1  1980 device_trees
-rwxr-xr-x    1 root     root         69836 Jan  1  1980 dtb.img
-rwxr-xr-x    1 root     root      13848576 Jan  1  1980 kernel.img
-rwxr-xr-x    1 root     root            48 Apr 10 13:54 kernel.img.md5
-rwxr-xr-x    1 root     root         35503 Jul  3 04:05 timeout-logo-1080.bmp.gz
1 Like

dunno, i never touched that dir before, but just noticed there is more stuff inside /flash on the sd-card variant. Could that be a failure of cross-upgrading from libreleec to coreelec in the past?

Would it help to copy the missing contents from /flash dir of sd-card?

It won’t hurt at least :wink:

1 Like

(Wonder why it never bugged me until upgrading to 9.03, thou.

Still no luck.

Also cat /proc/device-tree/le-dt-id still responds with gxbb_p200_2G_100M_t95m, so there hasn’t changed anything.

Any other idea how to update device tree on nand?

(Btw i see there are no *.ini files in flash here, are those made by your own?)

I don’t know for your box but boot.ini is mandatory on my C2 and N2. config.ini is not.

Phew! Fixed it with the earlier dd commands here in thread using my desired dtb file.

Works again :smiley:

Good to hear !

1 Like

Another reason that we don’t like internal installations, it just complicates something that would of been a copy and paste job.

1 Like

I’m getting can't open '/proc/device-tree/le-dt-id': No such file or directory on my N2 on a clean install of 9.0.3. I did copy g12b_a311d_odroid_n2 to root and rename it to dtb.img even though the root directory already had a dtb.img file there. I renamed that one to dtb.img.orig

I’m getting staggered audio on some 4k clips (SW9 and Elysium trailers). They play OK if I set the audio output to 2.0. Could that be related?

You can delete the original DTB file, it serves no purpose.
Where do you see the error you quoted?
And the 4.9 kernel doesn’t support LPCM, therefore you must set channels to 2.0, otherwise things will break.

When I SSH in as others have suggested to run cat /proc/device-tree/le-dt-id or is that not necessary? So the current builds for the N2 don’t support multi-channel audio?

This command was to check whether you are using the right DTB or not, but it’s too old and irrelevant in newer builds. If you take the DTB from the folder on the SD card, you’re guaranteed to have to correct file.
Multi channel PCM is not supported, but bitstream is. You can use the enable Transcode to AC3 option for formats that can’t be bitstreamed.

Awesome, thank you. I’ll try that. Thought I was going mad!

You don’t need to copy anything when you install the N2 image. The dtb is already there.

Good to know, thank you.