Unsupported dtb

When I SSH in as others have suggested to run cat /proc/device-tree/le-dt-id or is that not necessary? So the current builds for the N2 don’t support multi-channel audio?

This command was to check whether you are using the right DTB or not, but it’s too old and irrelevant in newer builds. If you take the DTB from the folder on the SD card, you’re guaranteed to have to correct file.
Multi channel PCM is not supported, but bitstream is. You can use the enable Transcode to AC3 option for formats that can’t be bitstreamed.

Awesome, thank you. I’ll try that. Thought I was going mad!

You don’t need to copy anything when you install the N2 image. The dtb is already there.

Good to know, thank you.

Hi there,

tried to install the latest nightly on my old 905X box (Mecool M8S Pro+). Flashed CE on sd card, copied gxl_p212_2g file from the provided distribution tree folder to the root directory and renamed it to dtb.img. So far so good, passed the distributors logo and goot a message saying “device tree is out of date”.

I am quite puzzled, because i am pretty sure that this is the correct dtb file (since i passed the distributors logo), so i do not really know what to do. It IS the most update dtb file that I could have or am I wrong there?

Where exactly did you get your dtb.img from? You have to copy it from the “device_trees” folder and not anywhere else.

Well, that is exactly what i did… :frowning:
Also did the same with CE 9.2.1 (not nightly), same result.

@NathanX can you SSH to your device and run the following command.


And paste the output.

The output is: unknown

What box do you have, did you do an internal installation?

It is a Mecool M8S Pro+ with CE running on MicroSD Card.

In previous versions of CE I always chose the file gxl_p212_2g for that box and it worked.

That’s the correct file, can you paste the output of the df command?

I hope this helps…?

output 905x df

You will have to redownload the image and reburn it again because I have just done a fresh install on an S905X device and can not reproduce this, the only way this would be repeatable is if you are using an old LE device tree.

Will do that, thanks a lot for your help

Thanks for your help. This helped me fix the boot message “your device tree is out of date”.
I had updated from libreelec 8.1.5 to coreelec 9.2.2 and suffered from the missing device_tree.

Do a clean CoreELEC install.

It’s the recommended method of installation.

You will have issues with remnants of LE on your system.

Thanks Kostaman,

I searched for the procedure, but couldn’t see the recommended way to clean up an existing install.
I have CoreELEC 9.2.2 installed on internal on my Beelink MINI MXIII II. What’s the easiest way to make it “clean”?
Can I do this just with ssh?
What kind of issues will the remnants of LE cause?

It’s caused unusual behaviour and bugs in the past for some.
Fresh is Best :wink:

You make the SD Card CE image

Make sure it all works.

Then install to internal as you’ve done before via SSH.


Don’t use an old LE backup either