Update your YouTube addon now

much appreciated - will try that today and report back :+1:

OK - i was overthinking it :grinning: - fooled by the weird error messages
installed the zip file in the first link and its working perfectly again
thanks very much for the help and patience :+1:

1 Like

Another update required to fix the latest break.

Hi all,

N2, CE 19.2 rc3, YouTube 6.8.16+matrix.1

YouTube has been working fine but today it will not play videos. I can search but not play videos, get the error to check logs.

2021-08-27 10:41:40.729 T:14855    INFO <general>: CActiveAESink::OpenSink - initialize sink
2021-08-27 10:41:40.753 T:14855    INFO <general>: CAESinkALSA::Initialize - Attempting to open device "iec958:CARD=AMLAUGESOUND,DEV=0"
2021-08-27 10:41:40.756 T:14855    INFO <general>: CAESinkALSA::Initialize - Opened device "iec958:CARD=AMLAUGESOUND,DEV=0,AES0=0x04,AES1=0x82,AES2=0x00,AES3=0x00"
2021-08-27 10:41:40.757 T:14855    INFO <general>: CAESinkALSA::InitializeHW - Your hardware does not support AE_FMT_FLOAT, trying other formats
2021-08-27 10:41:40.757 T:14855    INFO <general>: CAESinkALSA::InitializeHW - Using data format AE_FMT_S16NE
2021-08-27 10:41:48.914 T:8654     INFO <general>: initializing python engine.
2021-08-27 10:41:48.916 T:8654     INFO <general>: [plugin.video.youtube] Running: YouTube (6.8.16+matrix.1) on Matrix (Kodi-19.1) with Python 3.8.9
                                                   	Path: /play/
                                                   	Params: {'video_id': 'XAdL6GdURvI'}
2021-08-27 10:41:49.647 T:8654    ERROR <general>: /storage/.kodi/addons/script.module.urllib3/lib/urllib3/connectionpool.py:1013: InsecureRequestWarning: Unverified HTTPS request is being made to host 'www.youtube.com'. Adding certificate verification is strongly advised. See: https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
                                                     warnings.warn(
                                                   
2021-08-27 10:41:49.958 T:8654    ERROR <general>: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                                    - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                                   Error Type: <class 'AttributeError'>
                                                   Error Contents: 'NoneType' object has no attribute 'span'
                                                   Traceback (most recent call last):
                                                     File "/storage/.kodi/addons/plugin.video.youtube/resources/lib/default.py", line 15, in <module>
                                                       runner.run(__provider__)
                                                     File "/storage/.kodi/addons/plugin.video.youtube/resources/lib/youtube_plugin/kodion/runner.py", line 60, in run
                                                       __RUNNER__.run(provider, context)
                                                     File "/storage/.kodi/addons/plugin.video.youtube/resources/lib/youtube_plugin/kodion/impl/xbmc/xbmc_runner.py", line 33, in run
                                                       results = provider.navigate(context)
                                                     File "/storage/.kodi/addons/plugin.video.youtube/resources/lib/youtube_plugin/kodion/abstract_provider.py", line 105, in navigate
                                                       result = method(context, re_match)
                                                     File "/storage/.kodi/addons/plugin.video.youtube/resources/lib/youtube_plugin/kodion/register_provider_path.py", line 19, in wrapper
                                                       return func(*args, **kwargs)
                                                     File "/storage/.kodi/addons/plugin.video.youtube/resources/lib/youtube_plugin/youtube/provider.py", line 767, in on_play
                                                       return yt_play.play_video(self, context)
                                                     File "/storage/.kodi/addons/plugin.video.youtube/resources/lib/youtube_plugin/youtube/helper/yt_play.py", line 50, in play_video
                                                       video_streams = client.get_video_streams(context, video_id)
                                                     File "/storage/.kodi/addons/plugin.video.youtube/resources/lib/youtube_plugin/youtube/client/youtube.py", line 104, in get_video_streams
                                                       video_streams = video_info.load_stream_infos(video_id)
                                                     File "/storage/.kodi/addons/plugin.video.youtube/resources/lib/youtube_plugin/youtube/helper/video_info.py", line 537, in load_stream_infos
                                                       return self._method_get_video_info(video_id)
                                                     File "/storage/.kodi/addons/plugin.video.youtube/resources/lib/youtube_plugin/youtube/helper/video_info.py", line 965, in _method_get_video_info
                                                       self._calculate_n = ratebypass.CalculateN(js)
                                                     File "/storage/.kodi/addons/plugin.video.youtube/resources/lib/youtube_plugin/youtube/helper/ratebypass/ratebypass.py", line 22, in __init__
                                                       self.throttling_plan = get_throttling_plan(raw_code)
                                                     File "/storage/.kodi/addons/plugin.video.youtube/resources/lib/youtube_plugin/youtube/helper/ratebypass/ratebypass.py", line 257, in get_throttling_plan
                                                       transform_plan_raw = find_object_from_startpoint(raw_code, match.span()[1] - 1)
                                                   AttributeError: 'NoneType' object has no attribute 'span'
                                                   -->End of Python script error report<--
                                                   
2021-08-27 10:41:50.405 T:8654     INFO <general>: Python interpreter stopped

API Screen

Just one thread below.

1 Like

Thank you, that fixed it.

I’m new to this forum but have been using Coreelec Kodi for many years, running on Nexbox A95X B7N (2G version).

I’ve recently started having errors playing some videos in the Youtube addon (v6.8.15), with the same issue occurring in Coreelec 9.2.7, 19.2 RC3 and nightlies. The addon has worked fine in the past, and I’m not sure exactly when the problem started as I’ve been away for a few weeks.

In an attempt to fix the problem, I’ve done fresh installs of the above Coreelec versions, installed the Youtube addon and Inputstream Adaptive from the CoreElec Repo, and enabled MPEG-DASH.

I can sign in to Youtube and search for videos ok, but when I try to play some (most) I get an error and a popup saying the video failed to play. I think that the issue may be with 1080 or HD video, as some (possibly lower resolution) videos play fine.

I’ve posted the log to http://ix.io/3vHl and also the dmesg log to http://ix.io/3vHm

The error shown in the log (after the various callbacks) is:
“/storage/.kodi/addons/plugin.video.youtube/resources/lib/youtube_plugin/youtube/helper/signature/cipher.py”, line 93, in _load_javascript
param = int(param)
ValueError: invalid literal for int() with base 10: ‘function(c’
–>End of Python script error report<–
2021-08-12 08:24:14.011 T:4085753680 ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.youtube/play/?video_id=PVJvY358aMQ]

I’m not sure what else to try and would appreciate any assistance in resolving this.

Just after posting this, I found that the developer has released a new version 6.8.16 on Github that seems to have solved the problem. Apologies for not finding this first!

https://github.com/anxdpanic/plugin.video.youtube/releases/tag/v6.8.16

1 Like

Hi serafis,
Thank you for sharing. Here it is also working

I still have the same problem with the v 6.8.16.
Will there be an version update?

https://github.com/anxdpanic/plugin.video.youtube/releases/download/6.x.x-dev/plugin.video.youtube-6.8.17.alpha1+matrix.1.zip

About | FAQ | Terms of Service | Privacy Policy | Legal Notice