Updating M8S PRO+ S905X or not - beginner questions

na dont get me wrong.

i had some problems connecten via ssh with my mac.
but i solved the problems on my mac and i could connect now, but using libreelec as pass

but login on by ssh and typing :slight_smile: echo “meson-ir * mecool” > /storage/.config/rc_maps.cfg

and reboot does not help. IR doesnt work.

was this cmd correct?

hardware is
M8S PRO+ S905X 2GB-RAM & 16GB Flash
Os is on a Samsung 32GB microSD

but when booting without a sd, splash screens shows mecool.

thats why i used the mecool echo cmd.

echo “meson-ir * mecool” > /storage/.config/rc_maps.cfg

worked for me.

But to be on the safe side, just do a fresh install to a different sd/usb, I don’t know which device tree you need for your device, so check that first, by searching the forum, there is a link about device trees somewhere

@biesa, I’ve 3x of the same box as you have. This is the fastest way to setup everything correct in under 5 minutes:

Download CoreELEC 8.95.6 and unzip
Connect your Micro SD card to your Mac
Write the img-file to your Micro SD card doing the following:

diskutil list
diskutil unmountdisk /dev/disk2 # If your SD card is disk2
sudo dd if=X.img of=/dev/rdisk2 bs=1m # If your SD card is disk 2. Change X with the filename.

Copy gxl_p212_2g.dtb from the device tree folder to where the other dtb.img file is and overwrite it by renaming it to dtb.img
SSH into your box with coreelec as user and password
Run the following to active the remote

echo “meson-ir * mecool” > /storage/.config/rc_maps.cfg

Now everything should work just fine

1 Like

Did i.

new sd card with the latest img.

ssh via coreelec as pass worked:

Connection to 192.168.0.49 closed.
ssh 192.168.0.49 -l root
root@192.168.0.49’s password:
##############################################

CoreELEC

https://coreelec.org

##############################################

CoreELEC (official): 8.95.6 (S905.arm)
CoreELEC:~ # echo “meson-ir * mecool” > /storage/.config/rc_maps.cfg
CoreELEC:~ # echo “meson-ir * mecool” > /storage/.config/rc_maps.cfg
CoreELEC:~ # reboot
CoreELEC:~ # Connection to 192.168.0.49 closed by remote host.
Connection to 192.168.0.49 closed.

after reboot. remote is not working!

PS: login was root and pass was coreelec -
login & pass: coreelec does not work to login btw!

Well, that’s strange as I tested this yesterday and everything were just fine…

I’m sure the devs will look into this, especially if there are several people with a Mecool box where the remote is not responding. However, I mapped Mecool M8S PRO+ remote in July which you can try out in the meantime.

so how to fix it with those files?
can you guide me please?

can you tell me what to do by using ssh?
i am a bloody beginner

ssh into your box and run the following three commands separately. Hopefully it will work and the files will be loaded automatically after rebooting the device. If not, take a look in the Guides or Remote Controllers forum.

wget https://discourse.coreelec.org/uploads/default/original/1X/e143f4a2ae906e5770000587d00b6dbb6ad1175d.cfg -P /storage/.config/

wget https://discourse.coreelec.org/uploads/default/original/1X/1e04bd6a4b522f96d1fee8e857186f453af617f7 -P /storage/.config/rc_keymaps/

reboot

hmm not working after reboot.

##############################################

CoreELEC

##############################################

CoreELEC (official): 8.95.6 (S905.arm)
LibreELEC1:~ # wget https://discourse.coreelec.org/uploads/default/original/1X/e
143f4a2ae906e5770000587d00b6dbb6ad1175d.cfg -P /storage/.config/
Connecting to … (116.203.27.52:443)
e143f4a2ae906e577000 100% || 774 0:00:00 ETA
LibreELEC1:~ # wget https://discourse.coreelec.org/uploads/default/original/1X/1
e04bd6a4b522f96d1fee8e857186f453af617f7 -P /storage/.config/rc_keymaps/
Connecting to … (116.203.27.52:443)
1e04bd6a4b522f96d1fe 100% |
| 474 0:00:00 ETA
LibreELEC1:~ # reboot
LibreELEC1:~ # Connection to 192.168.0.49 closed by remote host.
Connection to 192.168.0.49 closed.

Try to make it from scratch


And after check that is different in your configuration. May be you need different config

isnt there an easy way to use my very common box with my ir remote?
why is there such a problem.
one previous version all worked.

will it help to install 8.95.5 and disable auto update?

You can. But in case of future update you will have the same issue.
This procedure is quite simple. You need just follow it.
Also you can upload your ir-remote picture, may be somebody can recognize it and help with right config

Also did you try A95X or minix_neo config?

you mean, typing all 3 commans via ssh?

echo “meson-ir * a95x” > /storage/.config/rc_maps.cfg echo “meson-ir * mecool” > /storage/.config/rc_maps.cfg echo “meson-ir * minix_neo” > /storage/.config/rc_maps.cfg

also wondering, that the new sd card with the *.6 img and after the ssh cmd which I tried today, is not working.

this has to be working 100% or am i wrong?

DId you copy and rename the dtb? I have a feeling you either didn’t or you are using an incompatible one as that is the only thing that would cause the issue your having.

Only one of them and reboot. Each command - different config, you have to use only one of them

well i took the right device tree file(gxl_p212_2g) deleted the exisitng img.dtb and renamed the device tree file to img.dtb and put it in the root dir. then i started first time the box with the card.

@boot2k3

ok will try each cmmd once and reboot and test.
but i have not much hope :frowning:

you need to rename the device tree dtb.img NOT img.dtb

sorry it was a typo. i renamed it the right way.

so no i took the 8.95.5 and the remote is working - now i am restoring the backups in order to get my settings and lib back.

i disabled the auto upodate function in order to keep my remote so far working.

is there any way to keep on working with this base in order to get all later versions of coreelec working with my IR as well?

doing no updates in he future should not be my goal, or shouldnt it´?

EDIT:
no i shouldnt!

I kept updating to *.6 and remote doesnt work.
so I tried a gain the 2 wget cmds above did a reboot and then tried the echo with mecool via ssh cmd again - reboot. and now its working!!

Question: am I safe now for further updates and the remote will keep on working or should Id´disable auto updates?

I would disable auto updates. Then wait a couple of days to see if anyone reports problems. Then update manually, in the meantime, make a systembackup & save it somewhere, not on the device

1 Like

If it works now, than before you did something wrong or had something in place where it prevents for ir to work.
It must work after future updates

1 Like