Upgrading from Odroid C2 to N2 -- DVB-T2 problems


I am upgrading from Odroid C2 to N2. Everything works as expected, except the two DVB-T2 USB adapters. With C2 (CoreELEC 9.0.3) everything was o.k. With N2 it becomes unreliable. Sometimes o.k., sometimes connection errors on client side. It occurs on all clients therefore I assume a problem on server side.

Examples for error messages in log file are:
2019-07-07 19:37:42.639 T:3809399664 ERROR: AddOnLog: Tvheadend HTSP Client: pvr.hts - Command unsubscribe failed: No response received
2019-07-07 19:37:47.640 T:3346203504 ERROR: AddOnLog: Tvheadend HTSP Client: pvr.hts - Command hello failed: No response received
2019-07-07 19:37:47.641 T:3346203504 ERROR: AddOnLog: Tvheadend HTSP Client: pvr.hts - failed to send hello

lsusb of the DVB-T2 devices:
Bus 001 Device 012: ID 0572:c688 Conexant Systems (Rockwell), Inc. Geniatech T230 DVB-T2 TV Stick
Bus 001 Device 014: ID 2040:0265 Hauppauge (WinTV dualHD)

Which driver(s) do I need? Is that a known problem expected to be fixed soon?

Thanks in advance for your help.

Update: Tried both DVB-T-drivers. “Latest kernel” and “crazy cat”.

Seems to work only with one stream at a moment. If I start a second stream (other MUX) on a second client the display on the first client freezes.

this may or may not be related, but there are issues with USB devices (including usb tv tuners) connected to the n2 at this time, there are ongoing discussions regards this in the ‘n2 test builds’ thread

It seems to be related…
Digging into the thread I found Odroid N2 test builds
Therefore I tried MicroUSB for the DVB sticks (with powered HUB) – first tests shows that it seems to work. Tested 4 simultaneous clients on 3 DVB bouquets.
In the test build from 20190708 DVB did not work at all (USB3 or MicroUSB).

I’ll give an update if something changes.

Thank you for the clue.

no problems, please feed back to the n2 test build thread, the more people test this the better eh!.