USB 3.0 Hub does not work (VIA VL812 chipset)

Hello friends. :slight_smile:

I just bought a simple USB 3.0 Hub because I am planning to connect two drives directly to my box.

Hub:
TP-Link UH400 4-Port-USB-3.0-Hub
https://www.tp-link.com/en/home-networking/computer-accessory/uh400/

Box:
X96 Max+ 4GB/64GB, S905X3
CoreELEC 9.2.2 stable

The drives work perfectly when connected to the box directly.

However, as soon as the USB Hub is between box and (any) HDD, the drive does not show up in CE.

Is there any way I can make it work? Adding a driver or something?
If not, can you recommend an alternative, working 4 port USB 3.0 Hub that is not too expensive?
I can still return the TP-Link Hub.

I appreciate your help! :slight_smile:

Edit:
According to this specsheet…
http://www.lancombg.com/data/UH400/Datasheet_en.pdf
…it uses the following chipset:
VIA VL812 Chipset

If that helps?

It’s a passive hub, therefore I think the power consumption of two HDDs cannot be delivered by one port of the box. Use an active hub instead.

1 Like

Oh sorry, I should have mentioned that right away…

Both HDDs are 3,5", externally powered.
So I thought the USB Hub would not have to be active?

Also, both HDDs spin up when connected to Hub/Box and also go to sleep after 15min as they should.
But the USB LEDs on the Hub don’t light up and the HDDs don’t show up in CE.
It’s the same when only one HDD is connected.

Accordingly, I believe the power is not an issue, or can it still be?

If the HDDs are self-powered, a power issue is very unlikely. Also passive hub is sufficient in that usecase.
Is the behaviour the same on all USB ports of the box?
Have you tried nightly?

I tried 3 of the 4 ports, same behavior.

Not yet, I will try to prepare another SD with the latest nightly today.

Is there a way to get feedback from one of the devs if a driver for this VIA chipset in the Hub is even integrated? Where is the best area to ask for something like that?

The manufacturer claims the following:
“Does not require drivers for Windows 10/ 8.1 / 8 / 7 / Vista / XP or Mac OS X and Linux systems.”
However, I guess our CE Linux is stripped to the necessary parts only, correct?

Looking for alternative chipsets in various simple hubs, I found the following:

  • VIA VL812: my hub, not working
  • VIA VL813
  • Realtek chipset, maybe RTS5401?
  • Genesys Logic GL3510
  • Genesys Logic GL3520

Does anyone use any working USB 3.0 Hub and could name it here and/or look up the chipset it uses?

I appreciate your help!

You should unplug USB hub and reboot the device. Then attach USB hub and later drivers too. After that post dmesg log from ssh terminal using

dmesg | paste
journalctl -l --no-pager | paste

and post both links you get.

Try the hub on a different computer/media box. May be the hub is defective.

The hub works perfectly on a Windows 10 computer.
Both HDDs connected, the status LEDs on the hub light up and the drives appear in Explorer right away.

What do you mean by “and later drivers too”?
What kind of drivers, where do I get them and how do I add them to CE?

Sorry, I meant DRIVES :slight_smile: So we can see in dmesg when usb hub is attached and when drives.

Ahh got it, thanks! :slight_smile:
Here are the links:

dmesg | paste
http://ix.io/2nnI

journalctl -l --no-pager | paste
http://ix.io/2nnJ

I hope it worked?

A lot of messages:

[ 98.993892@2] usb usb2-port1: config error
[ 99.945857@2] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?

Yes, I see that.
Obviously, the cable is not bad…

Also, it is not even detected as a USB 3.0 device

May 26 12:39:19 CoreELEC kernel: usb 1-2: new high-speed USB device number 2 using xhci-hcd
May 26 12:39:19 CoreELEC kernel: usb 1-2: New USB device found, idVendor=0bda, idProduct=5411
May 26 12:39:19 CoreELEC kernel: usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
May 26 12:39:19 CoreELEC kernel: usb 1-2: Product: 4-Port USB 2.0 Hub
May 26 12:39:19 CoreELEC kernel: usb 1-2: Manufacturer: Generic
May 26 12:39:19 CoreELEC kernel: hub 1-2:1.0: USB hub found
May 26 12:39:19 CoreELEC kernel: hub 1-2:1.0: 4 ports detected

I copied something just for testing in Windows from one of the drives to the internal SSD.
Reading at 170 MByte/s is hardly USB 2.0 speed. :wink:

Google shows bunch of hits without any real solution :frowning:

I just tested the latest nightly, same issue. :confused:

Is there any hope for this hub then or should I return it?

I would still welcome recommendations for hubs that actually work!

The next two on my list to try would be:

  • ICZI 01-RT: Genesys Logic GL3510 chip
  • UNITEK Y-3089: Realtek chip

I don’t see anything to get it working. I saw some workaround to disable usb and then enabling it back but for this it needs to identify where this hub is connected. And it is hard to explain :slight_smile:

Alright, thanks for your help! :slight_smile:

I will return the hub and I just ordered the aforementioned UNITEK hub with the Realtek chip.
Let’s hope that one works, I will feedback here.

If these hubs are a potential issue, maybe we should keep a list of chipsets that work?

Good news! :slight_smile:

The UNITEK hub works perfectly! :+1:
I still don’t know which Realtek chip exactly is in it, but it surely does the trick.

  • Both HDDs were detected right away.
  • Speed is great, 85-110Mbyte/s writing, 65-105 Mbyte/s reading via LAN.
  • Both HDDs go to sleep after 15min as they should.

If anyone is looking into a cheap hub for their box, this one is definitely worth a recommendation. :slight_smile:
It also has a Micro-USB port to supply more power for anyone using 2,5" drives.

1 Like

Can you run this command and post link?

lsusb -vv | paste

It looks like the paste service is down at the moment:

can’t get debug descriptor: Resource temporarily unavailable
curl: (60) SSL: no alternative certificate subject name matches target host name ‘paste.coreelec.org

I guess that command might tell us which Realtek chip it is? :slight_smile: