USB DVB Tuners and Odroid N2

Hi All

I fancy upgrading to a dual DVB-T2 tuner and was wondering if anyone has the Hauppauge WinTV-dual HD working on the N2.

If so, do you need to use Crazycat or Media Build drivers or will the CoreELEC drivers pick it up?

Also, how does IR (not bluetooth) remote perform alongside this dongle in CoreELEC on N2?

Thanks for your help!!

hi daaave, im afraid i cant comment on the Hauppauge WinTV-dual HD but i thought it might be of interest before you blow the bank on that you might consider instead 2 x Xbox One TV tuners, they are a LOT cheaper, i got 4 of them for £24 quid (£6 each!) and i can confirm they work perfectly with the N2, just a thought :slight_smile:

edit they are dvb-c/dvb-t/dvb-t2 capable.

1 Like

Thanks, I had no idea they were so cheap.

Edit - Just had a look and it looks like no recording functionality?

yeah no recording functionality when connected to a xbox one, plug it into a n2 and run tvheadend though and you can do what you want with it :-), there is no hardware crippling with them, its purely a ui limitation when plugged into the xbox one.

2 Likes

Wow that’s amazingly cheap then. Off to Amazon I go!!

Thanks very much for pointing this out to me :slight_smile:

pleasure :slight_smile: i have two hooked up so far and working a treat, happy days.

I have this tuner, and wasn’t able to get it going with the latest build. CE can see only one tuner, and seems like it has problems talking even to that one - I get a lot of
em28174 #0: writing to i2c device at 0xc8 failed (error=-5)
messages, and
[ ERROR] linuxdvb: Silicon Labs Si2168 #0 : DVB-T #0 - DTV_CLEAR failed [e=Inappropriate ioctl for device]

in the tvheadend

CE correctly loads the latest firmware, so that’s not likely the problem…

Worked ok in Pi3+libreelec.

Are you using the Crazycat drivers? Only Crazycat can pick up my existing Hauppage dongle properly (292e)

Am using whatever comes with the build (which loaded the filename that I was aware of for the stick - dvb-demod-si2168-b40-01.fw)

When I tried to replace it with what is in the repository ( https://github.com/CoreELEC/dvb-firmware) , it failed to load the fw.

If you go into

Addons / Program Addons / CoreELEC Module Drivers / Choose DVB Driver Module / DVB Drivers for TBS (with Crazycat additions)

it’ll probably pick it up properly after rebooting.

It should be pointed out that a dual-tuner HDHomerun Connect can be bought for about the same price as the WinTV-dual on Amazon.co.uk, doesn’t have USB power or driver woes, and has tonnes of support (via TVHeadend or standalone official Addon).

I previously had a Hauppage WinTV and haven’t looked back since going the HDHR route.

I’ve tried both crazycat and media_build drivers. Media_build works somewhat better - both see the second tuner, but crazycat find something else there and I can’t enable the second one, which I can with media_drive.

But neither still can see any muxes properly, with dmesg error
em28xx 1-1.2:1.0: writing to i2c device at 0xc8 failed (error=-5)

on trying to scan the mux.

TBH, I’d rather pick up two Xbox one tuners than one massive box. The Hauppauge worked ok on the Pi/LE, but the Pi was struggling with DVB-T2 decode, which is why I went N2.

Thanks for the info, glad I didn’t order one.

I have also decided to go the XBox One tuner route.

As I wrote, it worked fine on Pi/LE, and I like it’s in one box (so I can just connect one aerial cable). But it clearly has some problems right now. I’m not too fuss - yet, as I’m fine for DVB-T, it’s just when T2 comes along in about a half year I need something. If it won’t work by then, I’ll get the Xbox ones.

The Connect isn’t much bigger than a pi, so “massive box” is a bit of hyperbole.

connect is much larger than Hauppauge stick, from the . Odroid N2 box is already larger than Pi, and I have limited space.

Connect also needs another power source, and has to be connected to the box via an ethernet cable, so I’d have to get the Odroid close to two network sockets, or use twisted cable + wifi (which I don’t want to use).

If it works for you, great, I need something different.

I think the problem is with how the new kernel drivers work with the old kernel somewhere, so suspect it will be a problem until CE moves to the kernel that supports it natively (I think it’s 4.17 for both tuners).

Given that I don’t see any chance of CE moving to 4.17 or later kernel soonish, it would require someone to look at incorporating the Hauppauge bits into the existing drivers. No idea how hard/easy it is…

The Connect can be in an entirely different room than your N2. Mine is.

If I wanted things in a different room, I’d put the server tvheadend on my nas.

There’s no point in taking this any further. As I said, works for you, fine. Doesn’t work for me.