VIM3 2160p GUI issue

I’m starting the thread to document the issue I’m having with the VIM3 and using a 2160p GUI setting.

After getting my VIM3 I booted CoreELEC from an SD card and immediately did an installtoemmc, after rebooting I set my GUI to 2160p60 and had really bad screen corruption, see the following image and video.


Vid 20190817 171744-1.m4v (7.0 MB)

All other resolutions 1080p and below work perfectly, the issue only appears at 2160p. After some more testing I discovered that 2160p24 works fine until the CPU is loaded down, ie during a library scan, then the issues returns but the screen corruption isn’t as bad.

After talking with @adamg back and forth he asked my to test 2160p in Android to see if it was a hardware issue, I reflashed Android and tested 2160p60 and it worked perfectly. Now after reinstalling Android I no longer had CoreELEC on emmc so decided to just run it from an SD card. Once booted again I set the GUI to 2160p60 and to my surprise the issue had completely gone! So thinking it was maybe just a bad initial install I ran installtoemmc and rebooted… and the issue was back :frowning:

TLDR - In conclusion:-

CoreELEC running from SD card, 2160 GUI works perfectly.
CoreELEC running from emmc, 2160p GUI shows screen corruption.

As a note before anyone asks, it’s not a HDMI cable or TV issue, the VIM3 is a drop-in replacement for an Odroid N2 (same TV, same cable) and that works fine at 2160p60, but just to check I’ve tried multiple cables and a different 4k TV and the issues still occurs.

1 Like

The only thing I can think right now is some u-boot variable stored in env partition that is nuked when you do installtoemmc is responsible for this.

Try running the CE from SD card on VIM3 and play some 2160p 50 or 60fps video and while playback press some button to access the GUI, you will see something similar but not like in the video.

@Blakey Ok, it’s even more weird than that, I can confirm what you say that bringing up the GUI during playback of 2160p60 content does show the problem, however if you skip through the file and bring up the GUI enough times the problem goes away again.

Take a look at the following video, initially the problem is there but then at about the 20 second mark the problem goes away.

Sample

Hope we find the cause of the issue.

I’ve just pushed some changes for the VIM3 bootloader that resolve this issue, it will be available in tomorrow’s nightly.

@adamg awsome news… look forward to testing it. What was the issue?

@adamg Is it the 20190828 nightly that has the fix? Because I’ve just tried it and the problem still occurs :frowning:

Please provide a sample of the media causing you issues.

@adamg Any 4k media that is 50 or 60fps.

As a quick example try the file from the top of this thread:- MxqPro Hevc/4k frame drops and lags

With the GUI set 3840x2160@60 play the file and then bring up the either the info (i) or Player Process Info (o).

1 Like

I confirm, I have exactly the same problem.

We have removed internal install for VIM3 at this time because of this issue.

I can only think it’s a device tree issue as the N2 does not have this same problem.

Strange, I have the vim3 pro and have CE installed to emmc with gui set at 4096x2160p 23.98 and I no longer have the buggy osd since about 2 weeks ago. I did experience it and uploaded a video in another thread but at some point over the last week or two it was fixed and I havnt experienced it since

The “buggy” OSD happens when your display refresh rate is 4K@30Hz or higher.
You don’t need to run at 4096x2160.

1 Like

Yes as @TheCoolest has said…

The problems only presents itself at 4K 30hz/60hz.

1 Like

Unfortunately the corrupt GUI during 4K 60Hz playback also occurs when running from SD card.

Since the last update, it seems that the problem has disappeared for me.

@Bindou Even when playing 4K 60Hz content? Not just setting the GUI to 4K 60Hz, actually playing content that is 4K 60Hz and then bringing up the GUI.

You’re right, it does it again with the 4k @ 60, it’s the only format with which it does it again.