Vontar X4 - no CE boot without HDMI

Hi all,

I’m using Vontar X4 64GB+1Gbit LAN + ‘ne.aarch64-20.3’ image installed to emmc. DTB file is sc2_s905x4_4g_1gbit.dtb. Fact is if I startup a box without HDMI cable - it freezes just after a boot loader image. I see also some yellow stripes on a screen.

Does anybody familiar with such a problem? Any ideas how to fix? Thanks.

CoreELEC is a media player. Why you want to boot without a display?

It is related to the kernel driver what does not get a EDID so init fails.

I’ve had a similar issue with my N2 (running no). I found my N2 “stuck” on initial Hardkernel boot screen with strange yellow cast. I discovered that it was because my AV amp and/or TV were not powered up beforehand. Only recovery is to power cycle - not ideal. The older kernel used to allow boot to a default resolution and frame rate.

Hi Portisch,

fact is that initiation of TV’s HDMI works slower than TVbox, i.e. every time I

  1. switch on electricity for TV+TV-box - CE boots to black screen (I read some advises how to fix it related to previous versions of Kodi but not tested it on aarch64)
  2. if I switch on electricity for TV-box only (I prefer to use it as SPDIF standalone network audio player controlled by Yatse) - this time CE doesn’t boot at all.
  3. for safety reasons I power off/on all my network equipment by using automatic power switch, and CE fails with the boot.

I guess CE developers must envisage such annoying behavior of CE kernel. It would be great if anybody develop/change the kernel accordingly (at least to automatic booting to 1080p60hz). This will be real step forward for new CE releases. For example, ancient TX3mini easily boots up CE without HDMI, plus have fully working WakeOnLan as a big bonus compering to VontarX4 (still missing BL301 blob solution, working WOL even in NG release).

Feel free to fix it and make a PR to CoreELEC, thx.

The item is on list but very low down…

Same problem. Coreelec starts before the tv (connected tv and coreelec with alexa) and the screen remains black, it cannot be controlled with CORE, tvheadend does work. You have to switch to the coreelec hdmi input and reboot to show the main screen. On mecool ki pro it doesn’t happen at all, only on vontar x4

Refresh topic in case there is news about it

It’s already fixed in CE-21 nightly.

Is it solved in CE 21?

I don’t understand the question

The question is if CE-21 boot without HDMI is solved

@fr24 - @Portisch has answered you already! Fixed in CE-21 nightly.

1 Like

where is the topic? I can not find it

thank you!!

I have Omega stable on Vontar X4 connected to AVR. My AVR controls power supply for CoreElec and CoreElec boots, when I turn on AVR. Probably this is similar to no HDMI connection. On first boot, I get no sound from CoreElec. But it works correctly after restart.

I have noticed, that the difference in dmesg is that at first boot kernel gets option vout=576cvbs, while on next restart it gets vout=1080p60hz.

I have put option vout=‘1080p60hz’ in config.ini, but evidently it is not active at the first boot.