Vontar X4 (S905X4): install to eMMC?

Has anybody tried to force install to eMMC on a Vontar X4, forcing it with ceemmc -x?
I would like to avoid bricking the device!

1 Like

coreelec:ceemc [CoreELEC Wiki] from what I read here, for NG builds works.

1 Like

I have HK1X4 S905X4
Same as Vontar Transpeed

You can write to internal with success

However you will lose Android from internal.

Single boot only
No dual OS.

If you want to change Android you wil have to remove CoreELEC.

And flash image to internal.

Maybe is best to Boot CoreELEC from external.
If you want to use both OS.

Happy Testing

1 Like

I have the same problem. I Unbrick my device with Amlogic burning tool and Android image dowloaded from internet.

Do you have device with internal emmc 32 GB or 64 GB ?
Because I have this problem with 64GB and no problem with 32GB version.

mine is 64GB and cemmc -x worked perfectly

And which version did you use ? I tried 3 version CE 21 ng and CE 20.3 NG and CE 20.3 NE.

Paste a UART bootloader log on the 64gb version. This should show what is wrong.


@l.capriotti : nice to hear Vontar X4 works for you
Are you running ng or ne ? And using which dtb?
Please keep us informed.

ne, and using sc2_s905x4_4g_1gbit

1 Like


One more question:
Did you yes/no buy the extra Google Voice remote ? If yes: is this a BT or IR remote.
If someone else bought the extra remote, you can answer as well.
I ask because I prefer BT remote for CE as, in my experience, it works better than IR remote.
But this could be just personal experience.

Perhaps one more question:

Does anyone know where to download the Android firmware from.

I tried a few places but they seem to be a copy and currently are not available because too many downloads (e.g. Gdrive).

is Vontar_X4_1000M_230312_11_Amlo.zip the latest one and a good one to flash if anything goes wrong with for example ceemmc ?

I ask because I bought a Vontar X4 (it will take some time to be delivered) and want to be prepared.

1 Like

@blueyeti2023 tanks a lot !

You’re welcome. Just let me know if you need any help :grin:

1 Like

I received the Vontar X4 4GB/RAM and I now run 20.2 NE from eMMC.

Mostly everything works well. Analog audio is only exception. So I use Bluetooth audio.

Extra 2.4Ghz ‘voice’ remote works out of the box.

OpenVFD works as well

@blueyeti2023 : did you test Analog audio ?

By the way : analog audio initially did not work for my Ugoos X4 Pro 4GB/RAM either, but, that got fixed in dtb in between 20.1 NE and 20.2 NE. Perhaps a similar fix is possible for Vontar X4? I can provide help to test.

The temperature of the Vontar (~60°C) is also higher than the Ugoos (~50°C) one.

Overall nice box for its price.

Try this dtb for analog output.


1 Like

Thanks so much @vpeter for prompt help. !

unfortunately no analog audio yet

I did:

  • disable bluetooth
  • mount /flash rw
  • overwrite sc2_s905x4_4g_1gbit.dtb and dtb.img in /flash (not in /flash/device_trees)
  • mount /flash ro

rebooted (recall: from eMMC).

VontarX4:~ # md5sum /flash/dtb.img /flash/sc2_s905x4_4g_1gbit.dtb /flash/device_trees/sc2_s905x4_4g_1gbit.dtb
2a12710235746b9577aeda9afd21c14c  /flash/dtb.img
2a12710235746b9577aeda9afd21c14c  /flash/sc2_s905x4_4g_1gbit.dtb
e5103e7e9025694305915aef4bc0bdf3  /flash/device_trees/sc2_s905x4_4g_1gbit.dtb

Should I perhaps toothpick boot once?

Looks like something is different here.

Can you share Android dtb?


thanks again @vpeter for follow-up

$ md5sum dtb.img.gz
cac42a9aeac153fc6b14b5218bce3958  dtb.img.gz