Wetek Hub - new install - cannot boot

After I faced some issues with the upgrade I decided to perform a clean install of 9.2 - copied image to microSD, copied/renamed dtb file, etc.

Now I have a message ‘… update it to resume normal startup’ on TV screen
similar to what was mentioned here When starting the deco starts a countdown of 60 seconds
the only difference that my countdown start at 300.
Please advise on how to recover.

You need to re-read CoreELEC installation instructions more carefully, and use the correct DTB file.

DTB is correct. Tried Toothpick method as described in installation instructions without success.

You are using an incompatible dtb file.
Use the right one from the device_trees folder.

gxbb_p200_1G_wetek_hub.dtb was copied from device_trees to root and renamed to dtb.img

Can you try gxbb_p200.dtb just to see if you still have this problem?

The same result with another dtb.
Tried to boot 9.0.3 image with the similar result.

Which image file you try to install (whole name)?


Have you tried to install an older version, like 9.0.3 and update it to 9.2.0?

Tried 9.0.3 as mentioned earlier, without success.

And what version you tried to update from?

It is confusing because this message clearly indicates you are trying to use a wrong dtb…

I was running 9.0.3 for some time, then upgraded to 9.2.0
After noticing some minor issues I performed a clean install of 9.2.0 using microSD card.
On NAND I still have the old LE installation - can this cause issues?


Any advise how to recover from this situation?

Upload a screenshot of files on sd card with dates and sizes to check what could you do wrong

I re-flashed the card one more time and was able to boot the device. Not sure what was the root cause, but it could be either the card or a console cable connected to the device.
For some reasons the system cannot start normally - regular reboot gives me a blank screen, the only way to bring the system up is to press the update button on power-on (like in Toothpick method).

Fixed in the following way:

  • installed LE NAND image [to NAND, obviously]
  • rebooted the box with CoreELEC 9.2.0 microSD inserted
  • selected to boot from SD by remote control

Now it boots from CE microSD properly.
Thanks to all who responded.

P.S. one issue which I noticed earlier still remains with this clean install - Update Channel list is empty as well as a list of available versions.