❓ Which DTB do I use?

Hello,

I have Venz V10 Pro, it uses Amlogic SOC S905x, 2G (2G/16G internal memory), 100 Mbps ethernet. DTB that I used and that should be used for it is gxl_p212_2g.dtb.
Successfully used CoreELEC-Amlogic.arm-9.0.1-Generic.img.gz on SD card with gxl_p212_2g DTB image. After few days of testing successfully installed to internal memory on first try. So far it seems to be running solid and fast.

From Official Venz firmwares you can confirm it uses p212, 2g model so obviously gxl_p212_2g (original Android FW for unrooting and restoring to factory even contains p212 in its name).

I previously used original and official Venz FW dual boot LibreElec / Android combo but found out I almost never booted or used Android, LibreElec (8.0.2) was more responsive and overall better for my needs.
Recently found out about newer versions of LE and later of CoreElec, decided to try it out and I’m most satisfied with it.

Thanks a lot for submitting your device details.
This box is added to our download helper, now.

I’m sure, you won’t regret switching to CoreELEC. :slight_smile:

2 Likes

Hello,
i have bought a Tanix Tx3 Mini…
i think its the 2nd edition (no clock in front) - different remote…

Selected Tanix Tx3 mini dtb
When i boot to Corelec i get no response from remote…

(my father that has the 1st edition of tx3 mini, remote works fine)

What should i do ?
thank you…

Try the default gxl_p212 DTB.

Thank you i will try and report on my findings

Isn’t the tx3 mini a S905W device if so gxl_p281_1g should be correct and you may need to create a net remote file. check NEW Repo for Remote files (Thanks to Betatester)

1 Like

Today i tried the gxl_p212 for the tanix tx3 mini 2nd edition (without the clock in front)
remote doesnt work :slight_smile:
will try to create a net remote file… (dont know how will try)

Remote requires manual configuration if Tanix have upgraded it.

I hope you used the gxl_p281_1g
That Tx3 Mini has a different cheap old design remote control that was used in the old MXQ S805 ND T95N boxes.
Try the T95N


Cheap%20TX3%20Remote

thank you will try out and report

Hi,
I was looking for a DTB for the Magicsee N6 Max with the Rockchip 3399 XPU, 4 g DDR4 Ram and 1 g ethernet.
Excited about the idea of this project.

Unfortunately you are out of luck, because CoreELEC only supports Amlogic based devices.
AFAIK LibreELEC has a working Rockchip image, which you could try.

Shoot. I liked the looks of this fork. Thanks for the answer.

Does anyone have any experience with a TV box called R-Box Pro? Its another S912 w/3gb RAM & Gigabit Ethernet. It looks very very similar to the H96 Pro & H96 Pro + (it appears identical other than the brand name), the only difference I can see is in the IR remote. Could I get by with using the H96 DTB? If so, which one? -it looks like there is a dtb for the H96 Pro and H96 Pro + but I can’t see any hardware differences between the two. Has anyone been successful with CoreElec on this box?

I have a H96 Pro 3/16 and I think it’s identical with R-BOX Pro (different case only).
I did flash R-BOX Pro android image on it without any problem.
H96 Pro Plus has another WiFi chip built-in.
CE works on it with gxm_q201_3g.dtb
(I used gxm_q200_3g.dtb at the beginning but had an issue and the dtb change solved it)
Also had issue running CE from sd but moved CE to pen drive solved it.

hi there, i got a phicomm t1 box with amlogic s912/2G/16G/100M/android 7.12, cat /proc/device-tree/amlogic-dt-id returned gxm_q201_2g.
i tried all the device tree included but none was workable, coreelec just doesn’t boot. can anyone advice?
i leave the PCB photos on https://imgur.com/a/RL492Yw

If the (Android) boot loader on your box is locked, there is no way to install CE.

Another member tried but failed back in Feb EmuELEC: Retro Emulation Kodi Addon for CoreELEC!

There seems to be an unofficial version of CE running on PhiCom devices (distributed in a Chinese forum).
Unfortunately the developer didn’t contact us until now to officially add support, so we can’t help you with this problem.

since i succeed to make libreelec/kernel5.x to boot on recent build, i’d like to know the different between ce and le, is kernel the big deal?

@kostaman
yes, i read his posts, he encountered the same thing:frowning_face:

i see. i’m going to do some searching and try to contact that guy.