Which folder below are do i copy&paste the dtb file to on Odroid N2

which one of these folder do i paste into the dtb for my n2

right ni

right now ive got booting ,but it keeps booting into petiboot and then i have to select the corelecc ssd and then it boots no problem,ive set the ssd in the boot menu

See here. Please read the entire instruction set for N2 prior to installation, there are several options available.

ive read already thx, im using a ssd with a usap adapter to the n2 usb port,but what i need to know is once i copyed the dtb from the device tree its says to paste in the root folder ,there isnt a root folder so where do i paste the dtb to

read once more again more carefully. your error is right on the image

I challenge you to show me where in this article covering the installation of CoreELEC on Hardkernel devices it states to copy the dtb to the root.

dtb.img file is already there - no need to copy it manually.

What you show is the root folder, it must means the first folder (/) and is note named. The program you are using to view the folder hides extensions, you should be able to turn them on if you find that confusing. Based on that I suggest you follow up on the HK forums as it seems like a problem configuring PetitBoot.

Why are you replying to me instead of Hash70?

Configure petiboot to boot CoreELEC automatically or disable petiboot with a SPI Boot Select Switch on front.

this is the first time ive done this ever so im not sure what im doing thats why i asked you to tell as i was having trouble following the guide and on the install guide below it mentions about coping the dtb

thx very much for taking the time to explain,i updated petiboot to the lastest version and selected the usb ssd drive in the configuration menu but on reboot it always boots bck into petiboot and then i can see ssd ,if i hit enter it will boot into corelecc,if i switch to spi it wont boot

Sorry my apologies I guess I accidentally clicked the wrong reply button.

1 Like

Did you select the System configuaration option and change few things there? I assume not. Because there is an option to auto boot selected device.

is this the version of petiboot i should be using as i did read there was issues with earlier fw that was causing boot issues from a ssd

yes i selected auto boot in configure and listed the ssd in the boot menu

I don’t think you have read the wiki at all:

Petitboot (PB) version 2022-03-17 or better is required for use with CoreELEC. This is also the first edition including support for compressed Amlogic Multi-DTB.


i download the correct petiboot version and copy&paste to micro sd ,insert to n2 switch to spi and boot but it wont update ,tried another sd card but still the same

What version of CoreELEC are you using? I’ll try to replicate your issue on my N2.

19.5 rc2 thx