Widevine CDM install issue - running out of memory?

Newbie here so please be gentle. :slight_smile:

I am running Coreelec 19.3-Matrix (stable) on a S905 box with 2GB RAM booting off a 16GB SD card.

I have installed the Netflix plugin which installs InputStream Helper 0.5.8+matrix.1 and InputStream Adaptive

The InputStream Helper needs to download ChromeOS so that it can extract the Widevine CDM module due to Google’s distribution terms.

The issue is that the system consistently fails about 2/3 the way through the download and eventually reboots. I cannot get it to install the widevine CDM module.

Monitoring I see the disk space remains constant but free RAM drops constantly until the system chokes. I assume the download is being done to memory or a ram fs.

The pre-download message says “at least” 1015MB of disk space will be required but research suggests 3GB is required to hold the image and perform the extraction before it is discarded.

I have tried redirecting the temp location, but it seems the location is limited to the profile file system.

Is this expected for devices with only 2GB RAM ? (given the target platform for the build this would be odd ???)

Is there a documented way to manually update the system ? Say using another system (Linux or other) and copying the files over ?

Thanks in advance

I am unable to replicate this issue on a Nexbox A95X-B7N with 1 Gb memory and 8 Gb storage.

Please try again with a different SD Card.

Also: no log, no problem.

Thank you for your reply and for checking on similar low resource hardware.
Also thank you for link on how to access logs. I did look in normal /var/log location typical for *nix platforms before posting.
I have replicated issue and looked at logs but they do not appear to contain anything after the reboot caused by the issue (issue timestamp 22 November 20:16, system rebooted at 20:18)
Here are the logs:

This is a fresh install on a relatively new SANdisk class 10 16GB card, but I will obtain a new card and try again with a new image and report back.


The same issue occurs on a new different model card (32GB).
This time setting up the Netflix addon was the first thing done after installation.
As the logs are overwritten by the reboot there seems little point posting them.

This is with the gxl_p212_2g device tree. When I run top via a shell the device (A95X) show it as 2G of memory.

I then tried reimaging the card and using gxl_p212_1g to try replicating your working config, but that is unstable. I assume that I cannot use the 1g tree against a 2g device ?

Thanks in advance,

Have you already updated the underlying android to at least 7.1.x?

With S905x boxes, users can have varying levels of functionality installing CE 19.x without updating to a version of android >= 7.1.x. Anywhere from an obvious non starting boot loop to actually booting and then subsequently crashing without any obvious cause. In the latter case the box will usually crash when engaged in heavier processing and disk writing tasks, like getting widevine installed.

Anyhow long story short, if you’re still using the underlying android 6 and its incompatible boot loader, this is probably the reason for your frustration.

1 Like

retested with CoreELEC-Amlogic-ng.arm-19.4-Matrix_nightly_20211207-Generic.img.gz and gxl_p212_2g device tree and got same behaviour.

In case there is something to be seen, here are the logs against this build after producing the issue (and it rebooting itself).


Same issue with Coreelec 19.3-Matrix (stable) on a S905 box with 2GB RAM (TX5Pro) booting off a 32GB Usb Key.
I have installed DAZN plugin from kodinerds and, when installing Widevine, the process is blocking about 2/3 and reebots when download ChromeOS recovery image.

Have you find a solution?


I solved upgrading the box android firmware to 7.1.2
Thanks to @kshi

If you don’t want upgrade the firmware box, you can install latest CoreELEC Leia. I tested it before upgrading and everything worked well, also the installation of widevine. :slightly_smiling_face:

1 Like

Lol, I returned to post that I found from another post there was a requirement in NG builds for a minimum bootloader version. This is why Android 7.1 or above is required.

The box I had was originally Android 6.0 but I had upgraded previously to 7.0. So close !

So yes, I found a “release candidate” of Android 7.1.2 for the A95X 2GB / 8GB box and updated using the upgrade app (unit does not have a reset switch). Once that was done, the stable code for Coreelec 19.3-Matrix was able to finalise download of Widevine, extract, and install it.

This is resolved.

The Netflix add-on works with the installed version. Slyguy’s Disney+ Add-on finds this copy of Widevine installed and does not download using its own mechanism either (so better to setup in that order).


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.