X96 Air DTB issue

Hi. Just purchased a x96 air from Amazon.
4/32gb version with 100mb Lan.
The device shows x96_a100
Tried the 4gb DTB and box just sits on x96 boot screen.
Tried the 2g and boots to coreelec however only shows 2gb ram.
Tried Ram filling tools on Android and doesn’t seem to crash when using over 2gb ram.

Is there anyway to make sure without opening that the box is actually 4gb.
As may end up sending it back if not 4gb.


May be possible with uboot log.

The DTB observation is already a strong indication for Fake RAM.
RAM filling tools are often not appropriate test.
Better to recheck with https://play.google.com/store/apps/details?id=mark.fakedevicetest

1 Like

I had installed the fake device check and had a look.
Here is ram info. Not sure if there is anything untoward here.

Ok. After playing about further. The box now boots with the 4gb DTB for some reason.
Maybe an issue with 1st time booting coreelec.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.