X96 Max+ and ceemmc -x failure

Thank you, please let me know.

I just tested a single install on one of my devices with current 9.2.2 and it is working fine:

CoreELEC:~ # ceemmc -vx

Starting CoreELEC eMMC installation tool...

eMMC size: 0x0003a3e00000 [16GB]

Original partition table:
[mmcblk0p01]           bootloader  offset 0x000000000000, size 0x000000400000 [4 MB], unkn
[mmcblk0p02]                  env  offset 0x000000400000, size 0x000000800000 [8 MB], unkn
[mmcblk0p03]                 misc  offset 0x000000c00000, size 0x000000800000 [8 MB], code
[mmcblk0p04]                 logo  offset 0x000001400000, size 0x000000800000 [8 MB], code
[mmcblk0p05]                 dtbo  offset 0x000001c00000, size 0x000000800000 [8 MB], code
[mmcblk0p06]             reserved  offset 0x000002400000, size 0x000004000000 [64 MB], unkn
[mmcblk0p07]             CE_FLASH  offset 0x000006400000, size 0x000020000000 [512 MB], data
[mmcblk0p08]           CE_STORAGE  offset 0x000026400000, size 0x00037da00000 [14298 MB], data

Existing CoreELEC installation found on eMMC

[1] Make a copy of current CoreELEC installation on eMMC to current used SD or USB device

Please choose one option? [1]:

Also this is working here:

CoreELEC:~ # cat /sys/block/mmcblk0/size
30535680

I don’t know why it should not work on your device. What happening if installing in dual boot mode?

What does this mean? You install in single mode so only CE is on eMMC, Android get deleted.
How you where running ceemmc again? Botted from uSD/USB?

I wonder if it has something to do with the bootloader?

I was playing with my A95X Max trying to run from eMMC in single CE boot mode.

The process of installation seemed to go fine, apart from one warning message that read Warning: Could not find ‘dtbo’ partition!.

The 64Gb eMMC was seen and all the formatting and transfer of data looked good.

After the process was complete, I removed the original boot sourse and restarted but all that happened was that the vfd shows the word boot and stuck there with no further progress.

The one thing that I noticed that was different with the boot process was that the A95X Logo that normally appears as the first thing on screen when starting up was no longer being shown.

Putting the boot source back in the box enabled the original boot again.

When i ran the ceemmc process again it was interesting to see that it said ‘No CoreELEC installation found on eMMC’ which was unexpected.

So perhaps just a case of some boxes not capable of eMMC installation because of not having the necessary bootloader present?

This is warning only because some vendor name it different.
What happen if install in dual boot mode? Maybe there is something different in bootloader, yes. I don’t know because I have no such hardware -> unsupported by CE.

In dual boot mode, android boots but when switching to CE just a blank screen unless the original boot media is inserted.

In my case I’m not surprised that it didn’t work because I know that it’s been a struggle for people to provide custom Android ROM’s for this box because of the bootloader, so perhaps Bubble’s box has a similar kind of issue.

I boot directly from an internal SSD in my box anyway, which works well for me, so the use of the ceemmc tool was more of a what if rather than a desire but might indicate the kind of direction that the issue may be coming from.

Any of you have a chance to get a bootloader log? It have to be a UART log, dmesg is not enough.
When you do not want to open the device this is may a alternative: CoreELEC Team SDIO Debug Board

i’m goning to try dual boot, yes i boot from usb, to use the ceemmc command.
How i get ceemmc get running again , is by try to install(alm buring tool )with rom version x96p3 air because it has identical specs so it is my best bed. i can’t find original rom for this box

aml usb buringtool ease flash & bootloader that helped so de ceemc tool could clean install CE.

A have a FTDI adaptor and soldering and open up tis box is no problem, but how do i create a log do you have a guide ?

Just use putty and record every print on booting. Maybe there is some information why it is not working. When you post pictures of your opened box we can search the 4-pin UART header. Sometimes there is also the mark with RX/TX.

I fond 3 holes named DBUG with labeling i connected the FTDI adaptor(ft2332rl) GND>GND TX>RX RX>TX . In putty tick serial com3 try diffrent bauterate en other serial settings, check drivers comports also linux and windows10 get no output, even if i boot from CE usb NO OUTPUT.

i ordered a new adaptor to rule out if its broken FTDI adaptor.

Hello, I reinstall the stable version and now I have this: https://paste.debian.net/1141156/

It does not finish the process, I need to Ctrl+C to stop.

Ask me if need any info.

Regards.

What device you are using? It can not copy data to internal emmc as it’s read only.
And when you upgrade CE by tar file when booted from eMMC? Is the update working?

The information I found about this error:

The messages to me suggest either
a) a faulty piece of hardware
or
b) a low-level driver at fault
or
c) a USB disconnect caused by the HDD itself ...

So I guess it’s answer a).

@boot2k3 Can it be the eMMC sdio speed?

Also please remember your devices aren’t official supported:

Today downloaded and installed stable version 9.2.2 on Android box H96 MAX X3 4/64 1Gbit Lan (S905X3)

Unfortunately, it works only from the card and can not install on eMMC, android do not need, switching from the box Tanix TX3 mini where Coreelec works great, but the box is slower and can not handle everything.

And one more small thing, it seems to me as if the driver jammed even if I uploaded the correct rc_config, so the reaction is quite slow.

I attach the log here:

/$ ls -l /dev/ | paste
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0100 15526    0     0  100 15526      0  12410  0:00:01  0:00:01 --:--:-- 12410100 15526    0     0  100 15526      0   6894  0:00:02  0:00:02 --:--:--  6894100 15544  100    18  100 15526      7   6168  0:00:02  0:00:02 --:--:--  6178
http://ix.io/2ixr
/$ ls -l /sys/block/
total 0
lrwxrwxrwx    1 root     root             0 Apr 18 16:06 loop0 -> ../devices/virtual/block/loop0
lrwxrwxrwx    1 root     root             0 Apr 18 16:06 loop1 -> ../devices/virtual/block/loop1
lrwxrwxrwx    1 root     root             0 Apr 18 16:06 loop2 -> ../devices/virtual/block/loop2
lrwxrwxrwx    1 root     root             0 Apr 18 16:06 loop3 -> ../devices/virtual/block/loop3
lrwxrwxrwx    1 root     root             0 Apr 18 16:06 loop4 -> ../devices/virtual/block/loop4
lrwxrwxrwx    1 root     root             0 Apr 18 16:06 loop5 -> ../devices/virtual/block/loop5
lrwxrwxrwx    1 root     root             0 Apr 18 16:06 loop6 -> ../devices/virtual/block/loop6
lrwxrwxrwx    1 root     root             0 Apr 18 16:06 loop7 -> ../devices/virtual/block/loop7
lrwxrwxrwx    1 root     root             0 Jan  1  2015 mmcblk0 -> ../devices/platform/ffe07000.emmc/mmc_host/emmc/emmc:0001/block/mmcblk0
lrwxrwxrwx    1 root     root             0 Apr 18 16:06 mmcblk0boot0 -> ../devices/platform/ffe07000.emmc/mmc_host/emmc/emmc:0001/block/mmcblk0/mmcblk0boot0
lrwxrwxrwx    1 root     root             0 Apr 18 16:06 mmcblk0boot1 -> ../devices/platform/ffe07000.emmc/mmc_host/emmc/emmc:0001/block/mmcblk0/mmcblk0boot1
lrwxrwxrwx    1 root     root             0 Apr 18 16:06 mmcblk0rpmb -> ../devices/platform/ffe07000.emmc/mmc_host/emmc/emmc:0001/block/mmcblk0/mmcblk0rpmb
lrwxrwxrwx    1 root     root             0 Jan  1  2015 mmcblk1 -> ../devices/platform/ffe05000.sd/mmc_host/sd/sd:59b4/block/mmcblk1
/$ mount
devtmpfs on /dev type devtmpfs (rw,relatime,size=1958708k,nr_inodes=489677,mode=755)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
/dev/mmcblk1p1 on /flash type vfat (ro,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
/dev/loop0 on / type squashfs (ro,relatime)
/dev/mmcblk1p2 on /storage type ext4 (rw,noatime,data=ordered)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup2 on /sys/fs/cgroup/unified type cgroup2 (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
bpf on /sys/fs/bpf type bpf (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/debug type cgroup (rw,nosuid,nodev,noexec,relatime,debug)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
mqueue on /dev/mqueue type mqueue (rw,nosuid,nodev,noexec,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /var type tmpfs (rw,relatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev)
configfs on /sys/kernel/config type configfs (rw,nosuid,nodev,noexec,relatime)
/$ dmesg|paste
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0100 97578    0     0  100 97578      0  77875  0:00:01  0:00:01 --:--:-- 77937100 97578    0     0  100 97578      0  43291  0:00:02  0:00:02 --:--:-- 43291100 97596  100    18  100 97578      6  37257  0:00:03  0:00:02  0:00:01 37250100 97596  100    18  100 97578      6  37243  0:00:03  0:00:02  0:00:01 37250
http://ix.io/2ixw

and what is the error? any log? run ceemmc -vx and post all console output.

And it’s recomended to install first in dual boot mode if something is not working. Then you should be still able to remove it from internal. On single install it’s only way back by burncardmaker or USB burn tool.

Don’t know if slow emmc could be the reason… but it possible to try this dtb file and check
But it’s possible that need to wait some more time…
I remember long time syncthing when I had slow usb stick

Thanks Portisch,

My device is X96Max (sm1_s905x3_2g.dtb). When I upgrade by tar, it boot from USB. I test to power off the device and boot without the USB, it doesn’t boot, it stop in the X96Max+ logo (I have no Android, I had install to internall weeks ago but in a upgrade it doesn’t boot. So am again in USB boot).

The last upgrade work well.

Is there any test I could perform to confirm that my hardware is broken? something like badblocks?

Thanks for your great help.

Best regards.

Currently I have no idea, only a UART log of the bootloader will show what is going wrong.
I guess this X96 Max+ device is really not supported. Nobody of us do have such device so we can not tell you what is wrong.

Recover your device by an vendor Android ROM (image) and run CE from uSD/USB.

Thanks Portisch for your help.

I recover the device from Android image, and it run perfect installed in internal.

Then I installed stable CE and install to internal again: https://paste.debian.net/1141279/

It stay lot of time in 95% in this stage:

Copy all data from ‘/flash’ to ‘/media/CE_FLASH’
212.83M 100% 1017.96kB/s 0:03:24 (xfr#30, to-chk=0/32)

The I remove the USB stick and reboot, but it doesn’t boot, there es no X96max logo (yesterday was there).

I boot from USB and it start OK. Try to install to internal again: https://paste.debian.net/1141281/

Actually I have running with the USB stick and it works well, but I prefer to get it in internal.

Hope someone could debug it with UART log, I don’t know how to take this logs.

Best regards.

For some reason your eMMC is remounted to read-only mode in the middle of using ceemc tool. This is first problem needs to be solved. But the reason is unknown.

Thanks vpeter.

But the first install to internall from Android works well.

Weeks ago I had the nightlys images in the internall working well, but after a upgrade (maybe a month ago) it doesn’t boot anymore and I need to boot from USB.

I want to try a nightly from one or two month ago just to test, but there are not in relkai.coreelec.org.

Regards.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice