X96 Max+ and ceemmc -x failure

Also please do and post link.

 cat /proc/cpuinfo | paste


In the box says it is a S905X3. This is X96Max, not H96Max. About the max or max+, in the case puts X96Max, but in the boot logo puts X96Max+.

Here is the screenshot of hardware:

# cat /proc/cpuinfo | paste


So you have a X96 Max +


I am using sm1_s905x3_2g.dtb DTB file, is it the correct one?


Can you try with this dtb.img on USB? Replace the file, reboot and try to run ceemmc again. Hopely we will not see any writing errors.

new dtb! Made an error with previous file.
sm1_s905x3_2g-test1.dtb (68.9 KB)

Thanks vpeter,

I replace the dtb.img with your file and reboot. But it doesn’t work the ceemmc:

After the reboot, it stay in a black screen loop, there is no X96Max+ boot logo.

When I boot from USB it works well, but know there is no X96Max+ boot logo, directly goes to CoreElec splash and start Kodi.

Thank you very much for your help.


I think you should restore original android on it. It looks better with above dtb (no more emmc errors) but maybe still there are filesystem errors on emmc.

Also check if dtb.img has checksum 7d8856abc71549901c601f5f1b20df40

md5sum /flash/dtb.img

This one should have 7d8856abc71549901c601f5f1b20df40
sm1_s905x3_2g-test2.dtb (68.9 KB)

I have some problems uploading files here :frowning:

And as before run dmesg before and after ceemc and post all 3 logs.

Maybe I am doing something wrong:

In my laptop:

$ md5sum sm1_s905x3_2g-test1.dtb 
7d8856abc71549901c601f5f1b20df40  sm1_s905x3_2g-test1.dtb

Inside CE:

# md5sum /flash/dtb.img
a9a4633c78fab6ec522cc7e51498ad77  /flash/dtb.img

I plug the USB in the laptop, delete the USB dtb.img and copy the new one, then I umount correctly the USB.

Then try this when you already boot CE from uSD/USB

mount -o remount,rw /flash
wget -O /flash/dtb.img "https://discourse.coreelec.org/uploads/short-url/j83hKWRQD6Og4LszyJoZ8uLVubu.dtb"
mount -o remount,ro /flash
md5sum /flash/dtb.img

Then make all 3 logs. But only if md5sum is correct.
And remember to recover Android first please!

I didn’t recovery the Andoird yet, I will do it now.

But there is something strange, the dtb.img file different hash after reboot:

# md5sum /flash/dtb.img
a9a4633c78fab6ec522cc7e51498ad77  /flash/dtb.img
# mount -o remount,rw /flash
# wget -O /flash/dtb.img "https://discourse.coreelec.org/uploads/short-url/j83hKWRQD6Og4LszyJoZ8uLVubu.dtb"
Connecting to discourse.coreelec.org (
saving to '/flash/dtb.img'
dtb.img              100% |**********************************************************************************************************************************************| 70563  0:00:00 ETA
'/flash/dtb.img' saved
# sync
# mount -o remount,ro /flash
# md5sum /flash/dtb.img
7d8856abc71549901c601f5f1b20df40  /flash/dtb.img
# reboot

# md5sum /flash/dtb.img
a9a4633c78fab6ec522cc7e51498ad77  /flash/dtb.img

I am going to recovery the Android now and use the dtb you provided (7d8856abc71549901c601f5f1b20df40).


I think some values are changed in dtb on boot like RC remote type. That’s why checksum changed. Because checksum was correct after downloading it all is good.
Just recover android and repeat known steps :slight_smile: And maybe it will be last time :innocent:

1 Like


I flash the Android firmare. Burn the CE in a the USB with new dtb.img. Install CE and reboot.
Check the dtb hash:

# md5sum /flash/dtb.img 
7d8856abc71549901c601f5f1b20df40  /flash/dtb.img

And it works!!!

Thank you very much for your help! Are you going to update the new DTB in the stable image?

Best regards.


@Amfidiusz can you please try it again on your device with this dtb: X96 Max+ and ceemmc -x failure

jlazkano, yes, we will fix this dtb in general.

Who else has same problem? Djreedoo, Bubble, ???

Here are all sm1 dtb’s with same change.
sm1_s905x3_2g-test1.dtb (68.9 KB)
sm1_s905x3_2g_1gbit.dtb (68.9 KB)
sm1_s905x3_4g.dtb (68.9 KB)
sm1_s905x3_4g_1gbit.dtb (68.9 KB)
sm1_s905x3_4g_1gbit_slowsdio.dtb (68.9 KB)

@jlazkano can u please try to update if you booted from internal eMMC:

cd /storage/.update
wget https://relkai.coreelec.org/CoreELEC-Amlogic-ng.arm-9.2-nightly_20200415.tar

After reboot please make a dmesg log again, thx!

Hint: It may possible the internal install on eMMC is not booting anymore after update so please run ceemmc -x first when booted from internal eMMC and choose option 1 to create a backup to uSD/USB.
With this backup u can easily do a renew of the internal install. It will also already include the new dtb.

Hi Portisch,

This is the dmesg: http://ix.io/2iQE

Could I install the stable one?


Yes, please update it now again with stable or nightly (nightly is 9.2.2 + hotfixes).
Please run this commands before update for your safety:

mount -o remount,rw /flash
fdtput -t s /flash/dtb.img /emmc@ffe07000/emmc caps2 "MMC_CAP2_HS200"

Then the next update should be succesfull. You need to run it again after every update until the dtb is fixed.

Thanks @vpeter @Portisch , I have tried with tis dtb file stil not booting.
I also tried to get a bootlog by uart debug no succes.

It getting over my head, i love CE with kodi so much it’s doing everything i want, while runny from a fast microsd card.

Mebe in the future i try again to install on eMMC/NAND .

Bubble, you should do what jlazkano did. He reinstalled Android and boot CE from USB stick. Then he run dmesg | paste, run the ceemmc tool and run dmesg | paste again. This way we eventually figure out what is wrong. Which DTB file are you using?